SD Card Code 10

  kull34 20:44 19 Jun 2009

Hi All,

I have a new Toshiba, well six months old, and have just for the first time tried an SD card in the digital media card slot. The card is not showing in "my computer". In device manager it is showing with the yellow fault sign warning of a problem. Double clicking it gives this message "This device cannot start code 10" In Disc Management the card is not listed in the upper pane but is showing as a drive in the lower pane without a drive letter being assigned. If I try to assign a drive letter I get a message saying the operation failed to complete because the Disc Management console view is not up to date. It requests refreshing the view using the refresh task. That does nothing.

I have tried everything I can think of, reinstalled the driver and followed a number of suggestions after googling the problem. The MS Knowledge Base wasn't very helpful and a lot of people seem to have the same problem. I am now at a complete loss.

Any ideas would be most welcome.


  Fruit Bat /\0/\ 20:47 19 Jun 2009

Uninstall and reinstall the driver for the media card slot.

  kull34 21:32 19 Jun 2009

Hi Fruit Bat, Sorry I had to leave the computer for a while. I had reinstalled the drivers for the SD Card listed under disk drives when the card is in, for the storage Controllers and also Generic volume listed under Storage volumes. Have I covered the media card slot with that lot or have I missed something?


  kull34 21:38 19 Jun 2009

Meant to also say that I had updated the driver for SD host adaptors. By the way, forgot to state I am running Vista Home Premium SP2.


  Fruit Bat /\0/\ 22:14 19 Jun 2009

Is it working now you have reinstalled the drivers?

Have you tried right click the card and select initialise or format?

  kull34 22:18 20 Jun 2009

Hi Fruit Bat,

First chance I've had to get back to this. No it is not working and a format made no difference. I know the card reader is okay as a few days ago I took an up to date image with Acronis TI and then reinstalled the OS from the recovery media. The card worked fine then. I've now put the Acronis image back and the card isn't working. I've had loads of driver updates along the way from Toshiba for various things (but not the media card reader) via their Tempro service including a bios update. I am wondering if the bios update caused the problem. I am debating whether to put the bios back to the default setting.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?