Screen size settings won't stay

  polymath 19:57 21 Mar 2008

During a current troubleshooting session my screen size setting (in Win 98SE) reverted from 800*600 pixels to the default 640*480, and it won't budge; I've gone to Display in Device Manager many times, corrected, Applied & OKd it & rebooted, but it always reverts to default.

The background; it started with trying to reinstall an Epson 1240U scanner (having forgotten what a pain that could be!). It uninstalled OK, as far as I know, and I did delete all its remaining files/folders I could spot, that I knew it was safe to. Then the computer froze during the installation, needing a restart, and an error message appeared on the Desktop, headed 'Setup Wizard';
'Run-time error 429. ActiveX component can't create object'.
I don't know what ActiveX is apart from a Windows feature; or which object (presumably in the programming sense?), or why it couldn't be created.

I got the same error message, but headed 'ICC2000', when I tried to open my ISP's dialler (I don't know if ICC2000 is a Windows file/folder or specific to the ISP). I tried to Repair the dialler, but it still wouldn't work. In Startup (via msconfig), 2 new items had appeared; ICC2000 (with just the number 1 as the location), and (my ISP plus) Setup.
I unticked them in the startup list & rebooted, but they kept reappearing so I uninstalled the dialler (I can still connect, it's just more fiddly). I then successfully removed its Setup from the Startup list, and also ICC2000 (eventually; Ican't remember how), getting the Startup list back to normal.

Meanwhile I'd used Safe Mode, and thought Windows wouldn't stop booting into it! Then it dawned that it must be the screen settings, which is where we came in. (I haven't included all the sub-plots along the way).

Run-time error 429 hasn't appeared since uninstalling the dialler & sorting the Startup list, but I don't know if I've done anything that requires that ActiveX object (or what activities require it).

I tried System File Checker, but didn't spot any clues re screen settings. Restoring all the deleted.dll files(largely thanks to having once made a copy of all of them), didn't fix the screen problem either.

This display problem's making browsing very difficult, and web pages hard to read, including odd effects (such as scroll arrows being, confusingly, numbered). I did manage to reach the Helproom, search for my error message, view one thread, follow a link in it, reach a Microsoft error code wizard and get part of a list of links for error 429 (every step on the web seems to take about 10 minutes, much longer than normal even with my dialup connection*), but the computer then hung when trying to click a link; and everything was hard to read, with a textured background that this resolution produces. To see a whole web page requires lots of scrolling, and the scrolling often freezes things. Add to that the lack of a back button (the only possibility being to close the browser & start again), and perhaps you'll forgive me for not having searched here for the screen resolution problem!

I can just about post a message (and the PC Advisor site's one of the least hard to read), but if anyone has any ideas about the screen thing, something not needing a link would be ideal.

*I didn't choose not to use broadband by the way - our local community wireless scheme's only just making it possible!

  brundle 01:55 22 Mar 2008

Try replacing your system.ini file
click here

Make a backup as advised just in case.

  polymath 16:25 22 Mar 2008

Thanks brundle.
I've just remembered to try deliberately setting the screen size wrong, then resetting it correctly (which somehow seems to work for some settings), but it didn't help so I'll try your link.
If I have to admit defeat with following the link, I'll ask again here. (The nearest analogy I can think of for browsing the web in this screen setting is trying to win a cross-country race through treacle, blindfold!)

  brundle 17:10 22 Mar 2008

Or wallpapering the hall through the letterbox?

  brundle 17:18 22 Mar 2008

Something else to try, start menu/run, type


press return.

General tab will be highlighted, click Advanced, look for VGA 640x480x16, make sure it's not ticked.

  polymath 21:00 22 Mar 2008

I tried brundle's link, and got to, but couldn't read (or scroll to) much of it. I tried to bookmark it for future reference, but only succeeded in freezing the browser (so made a note instead!).
I then tried (via bookmark) the Wugnet website (which I've found useful for this kind of thing). I managed to get the front page (well, bits of), then to search for System.ini (thanks to the Enter key acting as a Go button, as the button had disappeared by then). I saw a page of the 1st 3 results, but further links didn't work (freeze time again).

I must say, as an artist I'm rather taken by how my photos look in this mode (like a Warhol-style print). Unfortunately, opening an image now freezes my normally happy image program, so I can't find out if this effect can be printed (and am wondering what else won't work!).

I've tried to restore system.ini with System File Checker, but it couldn't be found in the copy of Windows on the hard disk that reinstalls Windows. (I don't know if it should be there, or if it's created later, once Windows is running?) I ran the file checker again, but it didn't flag up system.ini. Does that mean system.ini's not the only suspect?
Find Files saw just 1 instance of system.ini, in C:\Windows, apparently created and modified today ( Is this normal?) I have Find Files set to show hidden files, but... maybe that setting too could be not working at the moment!

In case it's relevant, everything still seems to be enabled in System.ini (via msconfig), as it is in Win.ini.

I don't know what the file system.ini does (and can't look on the web!) - is it something to do with remembering stuff during a restart, like the one required when changing the screen size setting?

In Autoexec.bat, the first command doesn't immediately ring a bell; @C\WINDOWS\COMMAND\DelTree/YC:\WINDOWS\TEMP\ (if I've got that correctly). Perfectly normal I expect, but the 'Del' bit just caught my eye!

Any more ideas? I don't mind reinstalling Windows if it's the only solution (though preferably not a clean install). But I keep thinking there must be some really simple answer under my nose (these long troubleshooting sessions seem to be bad for clear thinking!)

Just saw your new replies - the General tab in msconfig has been looking normal, but just checked again before posting this, and the VDA etc item isn't ticked (and it's greyed out).

  polymath 14:11 23 Mar 2008

I just tried to print this topic when I got here, but couldn't (froze browser), and haven't found anything I can print, which may be some clue. Printing attempts get different results from different programs, including 'can't find printer' (from an open Wordpad document), nothing happening (right-clicking a Wordpad doc. icon & pressing Print), 'Thunderbird performed an illegal operation & will be shut down' (attempt to print an email). Tried a Windows Help topic (noticing on the way that only right-hand edge of Start Menu visible, & no way of dragging it - fortunately can shut down with Alt-f4/Close Program Box). Opened Help from Explorer (thank you, Quick Launch Bar), but trying to print a topic got an error message (see below if of any interest).

Speaking of email, it's acting normally (apart from low-res look & no printing), and isn't slowed down like the web. Oddly, my spam's reduced from 25-30 per day to just a few (but it might just be the spammers suddenly getting religion and attending all the Easter services).

Next I'm going to try another go at reinstalling the scanner, in case it makes something restore something. The various Epson instructions are contradictory and over-simplified, so this time I'm first going to read the stuff in my Troubleshooting Saga file. The section about the scanner is 2cm thick, so I may be some time.....

This is the Print button error message in Windows Help (via Explorer);
Internet Explorer Script error
An error has occurred in the script on this page.
Line: 1174. Char: 1. Error: Code: 0. URL: res://C:\WINDOWS\SYSTEM\SHDOCLC.DLL/preview.dig

I haven't searched for the abovementioned dll file yet (Find Files? Start Menu...) But if I can find it amongst my backed-up dll files I might try restoring it from there.

  brundle 14:20 23 Mar 2008

The .ini files are as you supposed, configuration files - if renaming/replacing them made no difference you can forget about them. The start up command you noticed is designed to delete all the temporary files in C:\Windows\temp at every boot.

Sounds as tho' 98 has got itself in a bit of a mess, as it's generally quick to re-install that is what I would do if I were you. You can try installing over the top of the current installation first, then backup and start afresh if that doesn't work.

  polymath 20:48 23 Mar 2008

Thanks Brundle - and for all your other replies.
Yes, I think I'll try reinstalling Windows next, instead of the scanner (probably quicker!).

I reach this thread via the link in the reply notification emails now, as it's only one step (every step on the web is currently painful - your letterbox analogy is spot on!)

I should have time sometime tomorrow, and will report back.

  polymath 21:31 24 Mar 2008

I've never done an 'over the top' Windows reinstallation, and looked out my notes from a previous, clean reinstall. For that, once I'd moved stuff I wanted to keep from C: to another partition, the process began with booting from a Windows Startup disk I'd made. Do I do the same to reinstall Windows 'over the top', but just say 'No' to formatting & go on from there? And does 'over the top' leave program files, drivers & data intact?

Sorry to ask here when there's so much help on the web, but the web's pretty much unusable with this screen size!

Brundle suggested I try replacing the System.ini file. I't's just occurred to me to see if Sisoft Sandra could throw any light on the whole business, and saw it has info about System.ini and Win.ini, which apparently are just 'placeholders' Is this normal? It says the actual files have been saved under the names of SYSTEM.TSH and WIN.TSH. I just wondered whether Windows could be looking in the wrong place, and if anything needs renaming? A SYSTEM.INI and a WIN.INI also exist (all 4 files are in C:\WINDOWS\SYSTEM). The TSH extension ones are larger than the INI ones; SYSTEM.INI 2kb, SYSTEM.TSH 3kb; WIN.INI 1kb, WIN.TSH 9kb. (I don't know what a .TSH file is!).

I've also realised that everything's disabled in the Win.ini and System.ini lists (in msconfig), not enabled as I thought. I suspect that last time I misread the little crosses as ticks (not thinking straight again!).

I managed to open Dr Watson today (after a struggle), and the Doc's diagnosis is 'does not appear to be a Windows 95 Plug-and-play compatible display driver'. Is that something that Win 98SE requires? (Or just a symptom of Altzeimers?) Most of the Dr Watson window was off the bottom of the screen, and there was no way of scrolling down, so I don't know if there's any more info there.
Mysteriously though, I can access the Start menu today!

  polymath 13:10 25 Mar 2008

Bouncing this in case anyone's online with suggestions.

More amnesia symtoms; have to re-do connection settings each time now (and Windows detected a 'new' printer, so have disconnected & uninstalled the printer for the duration).

Ironically, there's a new computer lined up for when I have time to clear the space & set it up! I still want to fix it this one though, for a few things new computers don't support.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017