123joey123 14:25 21 Feb 2008

I have a Canon scanner with a USB connection which has worked well for several years.
Yesterday I changed the motherboard to something much faster.Everything works well except the scanner.The computer indicates that there is new hardware but then insists that there is no connection. I have changed to another lead, re-inserted the drivers and changed USB ports from something that worked.
Anyone has a suggestion I would be grateful. Thanks

  johnnyrocker 14:30 21 Feb 2008

uninstall reinstall?


  keef66 14:36 21 Feb 2008

and if reinstalling doesn't work, check the Canon website to see if there's a software update for it

  123joey123 14:38 21 Feb 2008

Sorry,yes I did that.Uninstalled and reinstalled.

  chub_tor 15:30 21 Feb 2008

My Canon Scanner D1250U2F was tricky to get going after I upgraded and I had to go back to the Installation Booklet to find out the sequence.

1. Uninstall the driver and any existing Scanner software, make sure that no traces of it remain.

2. Switch off the PC and re-boot with the scanner connected

3. You should see the "Welcome to the Found New Hardware Wizard"

4. Use the CanoScan Setup utility CD Rom to install the driver or if you have the utility set up on your hard drive then use the Browse button to locate it.

4. Complete the Found New Hardware Wizard and then install any application programmes for the scanner.

  123joey123 15:43 21 Feb 2008

Yes,I tried all that. The strange thing is,I
used the scanner through the USB ports on the front of the computer. When I put the new motherboard in I couldn't use the front ports because the pins did not fit very well so I moved it to the back.I shouldn't think that would make any difference.I have decided to buy a new scanner as this one is quite ancient and am slightly worried the fault might exist on the new scanner. It seems a strange co-incidence that it only happened after the motherboard upgrade.That's computing!

  chub_tor 15:48 21 Feb 2008

Do other items work on the USB ports eg flash drives or card readers, printers? If not you may not have USB enabled in your new BIOS.

  woodchip 15:54 21 Feb 2008

Check you are putting the USB plug the right way up in the front ports, You cannot force it without Damage

  woodchip 15:56 21 Feb 2008

In Device Manager go to scanner and choose update drive, have the Scanner CD in the drive and point it to driver folder on the CD. These are Twain drivers

  123joey123 15:13 23 Feb 2008

For those who kindly tried to help I thought you'd be interested.
I went to device manager, clicked on Canon scan which had a question mark and inserted the USB cable and it burst into life.
Thanks all

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?