SATA sockets

  flipinek 09:09 05 Feb 2008
Locked

The plastic housing of SATA socket number 1 on my motherboard has broken and the cable won't stay connected. If I plug the system HDD into the second SATA socket I get Disk Boot Failure - no system disk.
Until I get a new motherboard, is the only option to plug the SATA system HDD into the IDE socket via a converter, or should it be possible to boot via SATA socket number 2?
If I get it working via a SATA-IDE converter will I be able to use SATA socket number 2 for a second non-system HDD to store data?

  johndrew 10:11 05 Feb 2008

You should be able to use one of the other SATA sockets by selecting it as the boot source either in BIOS or by pressing F8 during the starting sequence to get to the boot options screen. Select the drive there and your PC should boot.

I should add that I know this works on Asus boards but have no experience of others.

  wotbus@ 11:20 05 Feb 2008

Concur - johndrew is correct. WinXP F8 for Boot and/or Del to enter setup to change the boot source.
Yes to the second part of your question.

  flipinek 11:45 05 Feb 2008

Most of the time when I attempt to boot, BIOS is not seeing any disks. Occasionally it identifies "Serial Ch_1 Master Maxtor...", then "Updating ESCD...Success" then "Verifying DMI Pool Data" where it halts.
The same happens if I replace the HDD with a new Samsung SATA disk.
First Boot Device in BIOS Setup: I've tried C: and SCSI, both give the same result. The BIOS has never shown SATA disks but has been working with one for four years.

  johndrew 16:45 05 Feb 2008

Have you damaged the plug on the cable as well as the socket on the board? This should be quite hard to do.

If you are getting the `Boot disk failure` message in socket 1 you should be able to boot by going to socket 2/3/4 and then either changing in BIOS or (more easily) pressing F8 to select your boot source.

If the above fails then either you have done more damage to the board than you suggest, the cable is damaged, you have corrupted the data on the HDD or the HDD is damaged.

  flipinek 17:43 05 Feb 2008

First, thanks for the suggestions.
Yes, the plug on the cable has the remains of the socket jammed in it, so I've been using another cable.
I've done numerous re-boots and have sometimes had it as far as the black "Windows failed to load successfully" screen. Sometimes it locks up here, but a couple of times "Start Windows normally" or "Last known good configuration" have taken it a bit further but then it crashes and reboots. A BSOD showed very briefly one time. But on the next reboot it's just as likely to go back to "No devices" "Disk Boot failure" or stick on "Verifying DMI pool data". I've Googled these and tried various BIOS changes, including clearing CMOS, to no effect.
I've also tried fdisk /mbr from a boot floppy but just get "Bad Command or file name".
I'm currently thinking corrupted Windows installation and am about to reload XP on a different disk to check this.

  johndrew 19:35 05 Feb 2008

It`s probably unlikely you would get to a stage where you could run sfc /scannow to check for broken files, but you could try a repair with your original XP disk.

Have you tried booting in `Safe Mode` in case it`s recoverable from there?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

11 best portfolio websites for designers and artists

Office for Mac buying guide: Price, Office 2017 rumours & new features

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?