Sata External -IDE internal

  Terry Brown 21:30 24 Sep 2008
Locked

I have 2 IDE HDD on my computer and bought a external USB (500gb)( SATA as I later found out) for backups and storage,it was supplied as FAT32, and I formatted it to NTFS, the same as the rest of my system, however the performance is 'erratic' and very unreliable.
I have tried it on another comuter that uses SATA drives and it works perfect.
I am using a HP machine , and if I set the the USB SATA drive as master, it will find it no problem, but then my 2 IDE drives will not work, restoring it to normal restores the IDE drives, but leaves me with the same problem.
Is there a program that will enable me to wipe the USB drive and reformat it as FAT32 ?.
I have tried a winme 'FDISK' and it will not see the usb drive , only the fixed IDE drives.
Thanks for looking
Terry

  Jak_1 22:10 24 Sep 2008

To use a SATA drive your motherboard needs to be SATA enabled with the relevent drivers. As for using it as an external USB drive you still need SATA drivers to run the drive properly.

  DieSse 01:54 25 Sep 2008

If the external box is USB - what's inside it should not matter at all. SATA drives in USB boxes should work fine on any system - I've seen several in action as backup drives.

"if I set the the USB SATA drive as master"

I don't understand what you mean - SATA drives have no such setting.

The main problem with USB drives is the USB ports. Some don't work too well. Try in on another port if you can. If you're currently using a USB port not on the motherboard, change it to one that it. Via chipsets were always the most problematic.

Try without any other USB devices connected.

If it's on a hub - try it not on a hub.

I presume (from the capacity) this is a drive with an external power supply - please confirm you are using a power supply for it.

  Terry Brown 19:19 25 Sep 2008

The problem is,it was formatted as a Fat32 and I re-formatted it as NTFS, that is when the problems started.

I need to re-format it back to Fat32, any idea's.
Terry

  DieSse 22:09 25 Sep 2008

NTFS format should make no difference at all, and should work.

NTFS format cannot prevent a drive from being seen by the OS - in fact NTFS is the preferred format for large drives.

You could try re-formatting, using XPs Disk Manager - perhaps the format operation. didn't work well for some reason.

If you really want to dformat to FAT32, then you cannot do it with XP, as that will only format FAT32 partitions up to 32GB.

If you have a Seagate drive (any drive in your system, I believe), you may be able to do it with Seagate Disk Wizard. If it's a different maker you can look for a similar facility on their website. You should use the standalone floppy version.

  DieSse 22:11 25 Sep 2008

Repeat question

"if I set the the USB SATA drive as master"

I don't understand what you mean - SATA drives have no such setting.

  DieSse 22:19 25 Sep 2008

"the performance is 'erratic' and very unreliable"

Can you describe the symptoms - what actually happens.

"if I set the the USB SATA drive as master, it will find it no problem,"

What will find it? Otherwise what happens? Does it appear in Disk Manager? Showing what properties?

  Terry Brown 19:42 26 Sep 2008

The problem is sometimes it will save, sometimes not,sometimes it will say saved , then on re-opening the file cannot be found.
The drive has been tested on a different machine (with Sata drives), and it worked perfectly, put it into my machine (Packard Bell Bali), which apparantly has no facility for SATA, and it fails.
It worked under fat32, but I wanted it for backup's which is why I reformated it to NTFS.
DieSse
What I meant by master was , I unplugged the other IDE drives and left the USB drive connectd, and the computer econised it, although with no operating system, it would not 'run', but as sonn as I reconnected the IDE drives the problem returned.
I wil try a disk wizard an yes it is a powered drive (500gb).
Terry

  Terry Brown 20:06 27 Sep 2008

I have finally solved the problem.
It seems that you are only allowed 27 characters when you transfer to a SATA USB drive, which includes the sub folders.
e.g.d:/my documents/my music/rock & roll/rolling stones is 44 characters and will fail, however D;/music/rolling stones is 14 characters and will be OK.
I hope this will of help to someone else
Terry

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone