SATA drive not showing up

  herbie53 20:21 24 Mar 2009
Locked

Hi, I am trying to put a 500GB SATA drive in my computer to extract the data from it, as it is from another computer which has crashed. My computer primarily uses IDE drives, but it does have 2 SATA ports. I have tried plugging the drive into both SATA port 1 and 2 but it is not detected. I have also tried unplugging all drives except the SATA one but it is still not detected. My motherboard is a 755-a2. Any ideas?

  woodchip 20:24 24 Mar 2009

Have you loaded drivers for it?

  woodchip 20:25 24 Mar 2009

Have you loaded drivers for it?

PS also check Sata is turned on in BIOS

  herbie53 20:25 24 Mar 2009

I'm not configuring a RAID, or using a PCI controller for it, so are drivers needed?

  woodchip 20:26 24 Mar 2009

Drivers are needed if the Motherboard does no recognize it, thats why I just Said to look in BIOS to see if its turned on

  gazzaho 20:36 24 Mar 2009

As woodchip suggested check if SATA is switched on in the BIOS and also check that SATA is configured for IDE as opposed to Raid if the option exists.

  herbie53 20:36 24 Mar 2009

Just checked in the BIOS, the onboard SATA controller was already enabled. There was also the option for "SATA mode" or something similar with the option of IDE or RAID. I left it on IDE. The drive is spinning up but it is not showing up in device manager. Surely even if it did not have drivers it would show up as a device with a problem in device manager?

  herbie53 20:41 24 Mar 2009

I have also tried "Add Hardware" in control panel but it finds nothing - any ideas?

  gazzaho 20:42 24 Mar 2009

The fact that the computer it was in crashed may have something to do with it. Does it show up in Disk Management? You may not be able to recover the info on the drive as the file system may be corrupted, it may show in Disk Management as RAW or unformatted.

  herbie53 20:46 24 Mar 2009

Nope doesn't show up in disk management. When in its original computer it would get to the XP screen then restart and give options of safe mode, last known good config etc none of which boot successfully. I also booted that machine up in ubuntu, which would not read the disk saying it had a bad shutdown.

  herbie53 21:05 24 Mar 2009

Any ideas? could it be my SATA cable? I have just unwrapped it but has never been used before.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Is this the future of VR and AR?

Best iPad buying guide 2017

Comment regarder le Bureau des L├ęgendes en ligne ?