Sandisk USB flash memory not working in USB

  Wrighty 20:11 08 Jan 2009
Locked

Hi there,

I am running Window XP and trying to used SandDisk 1gb flash memory in USB ports. they are not reconised in the PC at all. When I go into my computer the flash drive is not reconised. I have tried formatting the USB drives but they are still not shown. I have been on Sandisk website to see if there is an updated driver but there is not for the flash drive I have or XP.

I have been told to update the bios which is something I will do at a last resort.

Any help would be gratefully received.

Wrighty

  woodchip 20:16 08 Jan 2009

Have you got Windows SP3 loaded? if not you should try it

  Wrighty 20:27 08 Jan 2009

Yes i have

  baldydave 20:49 08 Jan 2009

Are usb ports enabled?can you try something else in the usb ports?
Try a different usb port(i have one port which will work with somethings and not others)

  woodchip 11:11 09 Jan 2009

If its plugged into a Hub Try it Direct into Computer

  Wrighty 11:14 09 Jan 2009

It is directly into computer and USB are enabled.

I have tried the flash drive into a friends laptop which is running Vista and they are working find loading data no problem.

Just not shown on pc with XP. This has got me baffled.

  woodchip 11:40 09 Jan 2009

I use a HP one 1gb that works in my 98se and all my XP computer okay. So its the computer that is the problem. Have you tried in Device Manager uninstall all usb starting right at the bottom of USB then restart computer and let windows reload all the USB it finds

  Wrighty 13:09 09 Jan 2009

tried that thanks any other idea please. Tried in a laptop running XP home and works fine in that.

  kimtrnc 10:46 02 Apr 2009

Wrighty - did you solve this - I am going barmy with trying to get either of my USB flash drives (both perfectly happy in my laptop)to work in PC. File management shows both of them(one at a time, of course), but not My Computer, but despite several weeks of helpful advice from all quarters, I STILL cannot get either of them going. I'd happily buy a replacement, but I suspect that this is a computer thing, and not a hardware!

  john bunyan 11:21 02 Apr 2009

Worth a try: turn off PC - insert flash drive - restart PC

  global-killer 14:03 02 Apr 2009

If your comp only has USB 1 on the M/Board and not USB 2 it may well not work.

I have a friend who had same prob with a Sandisk
flash drive, he only had USB 1 on comp.

Only way I could solve it was put a £7.00 USB 2
PCI card in the comp.

Also found some H/Drives fitted into caddy's, mainly out off scrapped laptops suffered the same prob as well.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone