Is Sage Instant Accounts V12 Compatible

  ronalddonald 07:21 21 Apr 2008
Locked

Does anyone know if Sage Instant Accounts V12.00 is compaitble with windows Vista, released in 2006. I would appreciate advice over this issue.

  johndrew 09:26 21 Apr 2008

click here read System Requirements

  johndrew 09:29 21 Apr 2008

If that doesn`t answer you question fully, contact Sage and get confirmation click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017