Running Programs As Admin On Limited Account In XP

  Jake_027 20:07 30 Aug 2007
Locked

Hi,

On the family computer downstairs, there are 3 accounts. Mine, my mums and my dads. Mine is administrator (as I am the most IT literate) and the other two are limited to stop my parents running malware, as they will click ok to most things that come up. Practically all the programs work fine except one, Turbo Lister from eBay. They use this a lot so I can't get rid of it, but unless it runs as administrator it will not run. All that happens is the egg timer comes up for second then disappears, no error messages or anything. However right click and choose "run as" then use my account (an admin one) and it is fine. Now I don't want to give them my password as that completely undermines the whole point of them having limited accounts, nor do I want to change their accounts to admin as again this completely defeats the point. Is there any way I can use a registry trick or group policy editor or something similar so that I can allow this program to run a administrator and nothing else? Something that won't require my password every time. I have tried installing under the limited accounts but this won't work, it just terminates as it hasn't got admin rights.

If anyone can help with this it would be much appriciated

Thanks in advance

OS is XP PRO SP2 with all updates
Turbo lister: click here

  Clapton is God 20:21 30 Aug 2007

Try this:

The shortcut to this program probably sits in C:/Documents and Settings/Your Name/Start Menu/Programs

If so, try moving it to C:/Documents and Settings/All Users/Start Menu/Programs

  Jake_027 20:23 30 Aug 2007

Thanks but have already tried that. They can even browse in windows explorer to the file but they can' run it. I tried it myself.

Thanks for the suggestion

  Jake_027 21:11 30 Aug 2007

Bump

  Jake_027 22:21 30 Aug 2007

I am familiar with editing the registry and understand the risks it involves. I have a norton ghost backup of the pc and am familiar with how to import/export the registry. Is there any chance you could post iinstructions on how to do this-thanks.

  Jake_027 21:09 02 Sep 2007

It doesn't have a registry entry, but I did eventually solve this.

First I had to disable simple file sharing by going to folder options in control panel and under the view tab unticking use simple file sharing (recommended).

I then had to go to C:\Documents and Settings\All Users and in here was a folder called ebay. I had to go to the security tab and use the method above for finding users. Once I added them I had to give them full control for the ebay folder, and reboot. Now turbo lister works and they are still on limited accounts!

Thank you for the advice.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?