RTHDCPL.EXE - Illegal System DLL Relocation messag

  ukthesis 23:23 04 Apr 2007
Locked

Today, I ran XP Home Edition and when I booted up, this came up:

RTHDCPL.EXE - Illegal System DLL Relocation

Is there any easy and free way of fixing whatever problem this is?

Thanks.

  woodchip 23:25 04 Apr 2007
  Whaty 15:47 05 Apr 2007

You've posted a response on several threads apart from your own? And I'm a little confused by your response.

You don't need to delete the update, you just need to apply the fix.

See my post on this thread:- click here

If you follow these steps it will take you to and advise you how to apply the fix.

Good luck,
Terry

  Nellie2 16:13 05 Apr 2007

I've seen some of your other posts in other threads. It's probably best if you stick to your own thread otherwise things can get confusing.

Please do not uninstall the security update, it fixes a major vulnerability in Windows. click here

If the hotfix isn't working for you then there must be some other cause, have you tried downloading and installing the latest RealTek drivers?

If this doesn't work then you can request a hotfix from Microsoft using their online submission form. click here

  Whaty 20:36 05 Apr 2007

ukthesis, have you been able to resolve the problem on your PC yet?

This link was taken from another thread and it takes you straight to the download:-
click here

As Nellie2 says, probably best if you don't uninstall the security update. In fact, if you have tried to uninstall it it might be an idea to go to the Microsoft site and re-install it.

After you've reinstalled the update on your PC try running the fix again and see what happens.

If it still doesn't work please post back on this thread and try to explain exactly what you've done, the order you've done it, etc. etc.

Good luck,
Terry

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone