Roxio "drag-to-disc" not working

  twitcher 14:15 15 Jul 2007

I use Roxio Easy Media Creator 9 drag-to-disc to back up files. Recently, however, when I try to drop files onto a properly formatted disc I get a message “Files on this CD-ROM drive are read-only. You cannot copy or move files over to this CD-ROM drive.” When I click “Properties” on the Disc “Read only” is not checked. When I try to remove files dropped onto a disc using drag-to-disc I am refused permission with a message that the disc is “Read-only”. I have tried reinstalling drag-to-disc and reformatting the discs but to no avail. Does anybody know what might be causing the problem?

  skidzy 14:24 15 Jul 2007

cd-rom is read only,are you sure its a cd writer drive.

If a cd writer check enable writing is ticked click here

Have you removed any burning software ?
Any error codes ?

Some further tips:

Missing cd/dvd drives can be normally associated with the removal of burning software such as Nero/Roxio/Sonic/Easy CD Creator etc.
And not showing the drive in My Computer.

Try the below link ,if still no luck follow the Procedure of removing the upper and lower filters.

click here

If no joy with the above fix,try the Microsoft Guided Help

click here scroll down to the Guided help download and follow the instructions.

If still no joy,follow the manual fix below.

If you have further any error codes,please post them.

Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code:
Code 19, Code 31, Code 32, Code 39, or Code 41
, delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

.If in any doubt editing the registry,please create a System Restore point first and also backup your registry....The guidedhelp from Microsoft on backing up the registry is a good lesson for anyone to learn. click here

Creating a System Restore point:

Start/All Programs/Accessories/System Tools/System Restore…follow the prompts.

  twitcher 16:43 15 Jul 2007

Thanks Skidzy but none of the above helps. I too was concerned that the error message mentioned a CD-ROM drive but the drive concerned is a Seagate DVD+RW drive. It shows up in Explorer as such and recording is enabled. It shows "drag-to-disc" as being associated and the "drag to disc" shortcut on the desktop shows the DVD+RW as being loaded. When I click "View Disc Contents" those files already on disc are shown as being present. When I eject the disc I choose the "leave the disc open" option. However, I still can't add or remove files for the reasons shown in my original post.

  skidzy 17:00 15 Jul 2007

Have you tried a different media ?

Im not familiar with Roxio and its settings,though you could try the dma reset tool click here
this will make sure you have the DMA selected over PIO.

  twitcher 17:40 15 Jul 2007

Tried 3 different makes of DVD (including Sony & Philips) and a CD-RW, but with same result. Tried your DMA Reset Tool but that didn't work either. I've been using various versions of Roxio drag-to-disc for many years now and have never had any problems. I've even uninstalled my current version 9 and reinstalled version 8 but I still get the same error message, so I don't think it's got anything to do with Roxio.

  Andy1991 21:20 15 Jul 2007

Try right clicking ur drive, then go to Properties, and look for an option that says enable disk writing on this drive. I think u may need the CD in.

  skidzy 21:30 15 Jul 2007

going back to your original post,it seems like your system is just not recognising the writer facilities.

Have a look here,may well help click here

  laurie53 08:58 16 Jul 2007

I must admit I stopped using Roxio some time ago (bundled).

I found it very flaky, prone to hang the computer and produced too many totally unreadable discs.

Doesn't help your problem of course. Just a bit of background info.

  twitcher 19:15 16 Jul 2007

Skidzy - I downloaded the instructions for editing the registry and found that the value data box for the DVD+RW drive showed 1 instead of 2. I amended this, reinstalled version 9 of drag-to-disc and everything now seems to be OK.

Many thanks for your help.

  skidzy 19:42 16 Jul 2007

Glad your sorted,we got there in the end :-))

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?