Resurrecting external hard drive

  Marko797 14:10 12 Jun 2008

I have a 500gb ext HDD (Toshiba) which suddenly stopped working recently. Checked cables, all ok, checked fuse in plug, ok, but the HDD itself isn't 'whirring'.

I'm not concerned about the data on it, but just didn't want to go buy a new HDD, (although I could get a new Maxtor for £59 at PCW).

Anyone have any suggestions before it goes in the skip, as currently it's of no use?

Thnx in advance.

  Terry Brown 14:21 12 Jun 2008

It is unusual for a hard drive to suddenly stop, usually you get noises or beeps beforehand.
Have you checked the power is actually getting to the hard drive, i.e. different power cable or can you check that cable on something else; I presume it is a USB drive, have you tried another USB cable, as USB cables have been known to fail.
Are you running it via an adapter(i.e. 4 USB ports running off one USB socket, as they can (and do) fail.
Hope this helps

  Marko797 15:05 12 Jun 2008

yes it is unusual. No warning, just stopped playing. Power is getting to drive, and have tried another usb lead, but to no avail. No not running thru of multiple usb port, just the one on the laptop. Have tried it on the desktop usb too, with same results. It's as dead as a dodo. Tried flashing across switch terminals to eliminate the switch, and temporarily new hardware icon came up, but said new device might not work. It didn't.

  Marko797 15:11 12 Jun 2008

I removed the drive from the caddy, and plugged it into the desktop (into one of the IDE leads),and use one of the power supply leads, do you think this might be the acid test? If it doesn't work then, surely it's goosed?

Rationale is that the PC should pick the drive up if it's functional.

  Technotiger 15:13 12 Jun 2008

Have you checked it in Devices - maybe update driver there, although I know this is a very long-shot!

  Technotiger 15:15 12 Jun 2008

Acid test? Yes, maybe acid bath next!

  Marko797 15:22 12 Jun 2008

no, it's not in devices, I checked that one. The drive just will not start up (no sound of any movement at all - it's obviously not spinning). Bcos of that I suspected no power, but have bn thru the process of eliminating that as far as possible, as in above post.

  gazzaho 15:25 12 Jun 2008

I had 2 500GB Freecom drives stop working on me,so I took them out of their casing and tried them internally and both worked. They now live in Icybox enclosures and are working well.

Try removing the disk from its enclosure and plug it in internaly.

  Technotiger 15:27 12 Jun 2008

I guess it is a goner then. If it was mine, I would be very tempted to take it apart to see what makes them tick - I don't mean with a view to trying to repair it, but just to see exactly what one looks like inside. I know I have seen plenty of pictures etc of the workings, but I would still like to explore one!

  Technotiger 15:29 12 Jun 2008

Hi, read the post at 1511 above :-)

  gazzaho 15:32 12 Jun 2008

Sorry, I didn't read the post properly, I didn't realise you already plugged it in internally! Did you check master/slave settings? Although if the drive isn't spinning it would indicate a visit to the nearest bin.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires