Restored Win98 - cant access CDRom

  ronhud 23:24 18 Feb 2003

I have just had to restore Win98 (c:\windows)from a backup I took some weeks ago. Now my CD drive does not appear in Explorer. I have tried to update the driver but Windows tell me I have the best driver already installed.

In Device Manager I have the yellow flags on my CD and also Floppy, C:,D:,e: drives. The latter 4 seem to function ok.

I hope someone can point to an explanation and fix for these problems.

Ron Etherington.

  woodchip 23:30 18 Feb 2003

Click on and Remove All yellow mark's in Device manager then restart your comp and check them again

  ronhud 00:24 19 Feb 2003

Thanks woodchip for the quick response. I tried with the CDRom - in Device Manager removed it then rebooted. Windows didnt do anything diff on boot, I looked in Device Manager and there was no CDRom controller so I then went to Add/Remove hardware, Windows presented a list of devices but the CDRom wasnt there and the search for new hardware routine didnt find anything so I then went for manual selection. Selected the CDRom (MKEPanasonic) and Windows built a database etc. After reboot I was back where I started - a yellow flagged entry in DMan and no CD in Explorer.

The startup disk installs The MSCDEX driver and from DOS I can access the CD so I guess the cable connections etc are ok.

Ron Etherington

  woodchip 15:56 19 Feb 2003

Have you got a motherboard CD disc if you have try loading the IDE controller drivers from it

  Philip2 17:27 19 Feb 2003

Have you got the jumper set to master or slave??

  ronhud 17:33 19 Feb 2003

Thanks - I thought of downloading drivers from Toshiba before your suggestion and this worked and the CD is now available!

However the yellow flags are still there in Device Manager for all drive controllers except an entry for VIA Bus master PC IDE controller so I am wondering if this does the work and the other entries (Primary controller, secondary etc) are superfluous.

Ron Etherington

  woodchip 18:47 19 Feb 2003

Download and install VIA Bus master 4 in 1 drivers

  woodchip 18:48 19 Feb 2003

PS it's a patch for the VIA chipset bug

  ronhud 08:43 21 Feb 2003

Thanks for all the help - I have now found the reason so for anyone browsing with a simialr prob here it is.

I tried installing GoBack and it reported that Win98 had set my hard disks for 'DOS Compatibility Mode', I discovered that on the disk properties/performance screen there is a check box 'Disable all 32 bit protected-mode drivers' and it was checked!

Unchecking cured the problem and put my disk access back to its normal speed. If anyone wants to follow this up I strongly recommend looking at the following first:-
click here;EN-US;130179

Ron Etherington

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017