Removing A Touchpad Completely From A Laptop

  jimforrest 06:15 11 Feb 2015

I did manage this once before - but I can't for the life of me remember how! I can't get on with touchpads because the heel of my hand always seems to touch the pad whilst typing and moves the curser. On my spare laptop - an Acer Aspire - I tried to disable the pad but the disable button in Task Manager is greyed out.

It's difficult to even identify the pad as it is listed as a USB mouse. It's only correctly identified as the Synaptics Touchpad when you look at the properties page. But how, apart from opening the case and disconnecting the ribbon cable, can it be disabled?

  Daisy_Michael 06:55 11 Feb 2015

The Function (Fn) Key and F7 Key together would give you an option to enable & disable the touch-pad.

Else you may uninstall the driver of it.

See click here, explaining the same in a more detailed way.

  AroundAgain 08:09 11 Feb 2015

I'm sure there will be a way of disabling the touchpad. Maybe, if you post the make, model etc of your laptop, the information required will be on the internet, or here, as to how to disale it.

Failing that, rather than doing something as extreme as removing or pulling connections, try masking the touch pad with something like a laminating pouch that has been put through the laminator - (or thin card et) then securing it to the front of your laptop.

I've known a friend do this and it's worked extremely well. I'm fortunate enough to be able to disable my touchpad but, on the occasions when I forget to take the mouse, I can still use the laptop ;)

  rdave13 11:53 11 Feb 2015

If you can't find the drivers on the manufacturers page the generic one's are here.

Install the driver and reboot. Go to control panel then select mouse, or right click the icon in the notification area. Select pointing device properties. Select Device settings tab then select the disable tab. Click apply and ok.

1]: [click here

  jimforrest 17:58 11 Feb 2015

I can't disable the driver because that option is greyed out. Similarly, if I delete the driver it automatically reloads it every time I reboot! the Fn + F7 is ok - but you have to do it every time after a reboot (and will be halfway through an email before remembering!)

Going back to the beginning - with no external mouse connected the touchpad is listed as a PS2 Mouse (not a pad), and under Control Panel it is shown as a mouse complete with wheel! If I set it's responses really slow so it's ineffective, when I plug an external mouse it has the same responses.

Plugging an external mouse in shows as a USB pointing device - but whatever settings are set for one, applies to the other.

  robin_x 18:59 11 Feb 2015

I have a Synaptics Pointing Device Trackpad on my Compaq CQ-61.

There's a small button on the dge of the trackpad, with LED, to turn it on or off but I know many laptops don't have a physical switch.

Additionally, the Synaptics software installed from the offical driver download on HP site for my model, has a tray icon by the clock on the taskbar (may be in Hidden icons).

When I double click the icon to open the configuration options, there are the following:

  1. There is a Palm Check to help reduce accidental contacts.

  2. I can Enable or Disable the Trackpad which has the same effect as pressing the physical button and the LED changes colour.

The changes I make are persistent between reboots.

Maybe it's your Fn+F7 that isn't but the Tray Icon disable might be?

If you haven't got a Tray Icon I would say you haven't got the full package installed, or not starting with Windows.


Or you may just have to give up and adopt new habits or pull the cable as you were originally thinking.

  BRYNIT 20:16 11 Feb 2015

Don't know if it will work but worth a try. Open msconfig.exe look in the start up tab, if you find the touch pad listed remove the tick also go into Services tab and do the same click apply/OK. Hopefully it will not start when you reboot the laptop.

  rdave13 23:17 11 Feb 2015

In device manager does the mouse, when connected, (not the TouchPad) show as HID - compliant?

  jimforrest 00:35 12 Feb 2015

Yes it does Rdave. However, needed to get it sorted so out of desperation I split the casing and pulled the ribbon cable. So it's solved - not perhaps the most elegant way, but sorted anyway!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?