Remote Desktop stops Wireless Network Card

  first500 15:24 02 Nov 2005

This rather defeats the object!! I have set up Remote Desktop to view my desktop machine on my laptop via my local Wireless Network. I was formerly using an ad hoc (peer to peer) setup and it worked fine.

I have just installed a Netgear Wireless router/modem, and the network is working fine in all respects except..... when I call the desktop using remote desktop from my laptop, the wireless connection on the desktop PC now disconnects. (Also crashed when using "Switch User")

I have tried the fix given on another thread to add a KeepRasConnections value to the Registry. This did allow "Switch User" to work without killing the wireless connection, but still crashes when Remote Desktop is initiated.

The desktop machine does not cut off until after the blue screen has appeared and the message "To begin Click your User Name" message has appeared.

Any suggestions gratefully appreciated

  BigMoFoT 17:13 02 Nov 2005

Are you logging on to the PC as the same user that is already logged in or is it a different user?

I certainly think it is down to the user - you should not get "to begin click your username" when using RDP.

To use RDP you must have a password on at least one account other than the administrators...

  first500 17:21 02 Nov 2005

Sorry BigMoFoT, I may have mislead you. The way it worked (before I put the router in) which I think is how it is SUPPOSED to work, is that I would initiate RDP from the laptop, then the desktop would "Shut down" to the blue Logged Off screen, to show that another user is (remotely) using the desktop.

This is the screen that allows a user to log back on to the desktop, which would naturally then interrupt the RDP session.

What I was trying to point out in my clumsy way was that the wireless connection on the desktop seems to cut off AFTER the log back on screen has appeared. I am assuming therefore that a successful RDP connection was made, but got interrupted due to the network card switching off. Hope this helps.

  BigMoFoT 17:29 02 Nov 2005

Ok so when you go in via RDP are you loggin in as the same user?

What have you got your wireless connection set to, i.e. access pont, ad hoc..

  BigMoFoT 17:30 02 Nov 2005

Just thought of summet..

Is windows looking after your wireless connection or is it a 3rd party app?

  first500 18:15 02 Nov 2005

1. Yes - I log in as same user, but that has not been a problem in the past, and I don't see why that should disable the network connection???
2. Wireless Connection is set to Infrastructure. I can log on to shared drives on the desktop from the laptop, and remote print from laptop to my printer (which is connected to the desktop), but no RDP. As I said, the network in all other respects seems to behave ok
3. The Wireless Connection is controlled by the Belkin Wireless Utility, not the Windows XP app.

Hope this helps!

  mgmcc 08:55 03 Nov 2005

You could always use an application such as RealVNC to "remote control" one PC from another. I use it and have done so to control another PC over the internet as well as controlling computers in my LAN, including running a Windows PC from a Mac both of which are networked via a router. This hasn't caused a problem with a "wireless" connection.

RealVNC - click here

  first500 21:08 03 Nov 2005

I have experimented with setting up another user account, and using Fast User Switching on the Log Off option.

Same problem - to recap the network card stops whilst the Blue Screen with the Users names shows, and only restarts when the new user logs in.

Any ideas gratefully accepted.

  BigMoFoT 16:27 09 Nov 2005

Sorry for the delay in replying - christ it's been over a week!

Provided your account isn't screwed try letting windows run your wireless connection rather than the belkin app - not sure about the belkin stuff but Windows uses a service that will run even when a log off occurs.

  first500 16:58 09 Nov 2005

Thanks BigMoFoT. By coincidence,I have just finished reloading the Belkin Card drivers, and fingers crossed, it looks like the prob is fixed. If it reoccurs I will take your advice.

Many thanks for trying to help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How secure is your Wi-Fi?

AMD vs Intel: we put the most powerful desktops for designers and artists head-to-head

iPhone tips & tricks

Les meilleurs ordinateurs portables 2017