Registry problems - XP

  number cruncher 23:05 03 Dec 2006
Locked

I'm getting a problem with Windows XP where it won't boot into Windows because the file WINDOWS\SYSTEM32\CONFIG\SYSTEM is corrupt. I've read various posts/MS Knowledge base articles about this and they suggest copying the SYSTEM file and other registry files from WINDOWS\REPAIR - but the SYSTEM file doesn't exist in the WINDOWS\REPAIR directory on my computer (although the directory exists, and contains other files such as SOFTWARE). Also the MS Knowledge base advises not using this approach anyway when you have an OEM version of XP - which mine is (Mesh). Any suggestions what to do? Thanks

  skidzy 23:27 03 Dec 2006

You could try the system file checker in safe mode (Tap F8 on startup)..im not totally sure if this will work in safe mode,but if so

In safe mode: start/run/type sfc /scannow

Understanding SFC

click here

  number cruncher 08:11 04 Dec 2006

Thanks for this - I've not got access to the problem machine at present, will try later. But can I run this directly from a DOS prompt (I can't get into Windows at all at present)?

  rawprawn 09:55 04 Dec 2006

I don't think you can run sfc from the cmd prompt.
I think a "Repair may be your best option.
click here
Print it out and take it with you to tour errant machine.

  rawprawn 09:58 04 Dec 2006

Sorry, should have finished reading your post properly. I think Mesh have a different system, it may be best to use their support.

  number cruncher 13:33 04 Dec 2006

Cheers for this

It is a Mesh PC, but is 4 years old and so out of warranty - will try Tech Support anyhow. I've got their recovery disk, but not clear whether it has any useful software on it other than the Windows setup stuff.

I've seen similar guidance on other threads on this sort of issue, but it does seem strange that Windows is set up in such a way that you need to ignore the first 'repair' option following the loading of setup to get to the one you want!

One further bit of advice - I've got the most important things bacekd up, but there are a few things I've done recently that I'd prefer not to use. Can you use a CD-writer from the command prompt (my simplistic attempts to do so have failed so far...)?

  rawprawn 13:55 04 Dec 2006

I agree about the first Repair seeming strange, but do follow the instructions. To the best of my knowledge you cannot run your CD writer from the cmd prompt.
Maybe some body can confirm this or show you how.
I have never had a Mesh machine, but a friend has one and if I remember rightly if you hit F11 on boot (not sure of number) you get three different options, something like "Last good configuration", "Repair"
or "Factory settings" have you tried this??

  number cruncher 14:38 04 Dec 2006

Thanks for the F11 suggestion - wasn't aware of that but will give it a go.

Any suggestions from anyone on else on using CD writers (or other mass media) from the cmd prompt would be helpful.

  number cruncher 23:03 04 Dec 2006

Update - not very good though...

I followed the steps above through setup - enter at the first screen (ie not going into recovery console) and then aftere accepting the Windows licence agreement, expected to get an option to repair the installation as in the example link - but this didn't appear; the only option was to install Windows which I didn't really want (assuming that would over-write everything...).

So came out of that and tried manually copying registry files (SYSTEM etc) from repair directory. Had to copy a file called system.sav as there was no file called just system... However, re-booting from here just gives me a blue screen.

Do you think this might be recoverable, or am I best reinstalling Windows XP from scratch (and if so, do I need to reformat first, or can I try just following the install option?

  rawprawn 08:17 05 Dec 2006

Did you try F11? I still think having a word with Mesh support woud be a good idea, I am pretty certain that Mesh computers are somehow configuerd differently and the OEM disc that they gave you will not run as a normal XP.

  number cruncher 11:03 05 Dec 2006

I tried F11 (and F9/10/12) at various points and nothing seemed to happen. Have been on to Mesh website and found this:

click here

which basically suggests one of the routes I've already tried - but I don't think it suggests anything unusual about their recovery CD. Will contact Mesh support anyway, although its not easy to find a time when they're open and I'm by the right PC...

Thanks for all the suggestions, by the way - keep them coming!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Aardman's new YouTube channel to share the work of independent animators

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017