Registry help needed

  chub_tor 10:39 12 Nov 2009

I recently upgraded my Vista partition to Windows 7, leaving my XP partition untouched. I plugged in an 8Gb USB stick while in Win7 and promptly crashed the system to a blue screen. Reboot try a 4Gb drive that installed OK in Win 7. Try the 8Gb drive in XP and it is fine, try the same 8Gb drive in another Win 7 computer and it is fine but when on my dual boot machine it does not show up in Computer, it has no drive letter, no volume name and cannot be accessed.

I have formatted it in both Fat32 and NTFS using the XP partition and with Acronis Disk Manager with no success.

It does show up in Disk Management but I cannot change the drive letter (message says it is because Disk Manager needs to be refreshed but doing so makes no difference). I have tried getting a drive letter via Acronis - it shows as disk 6 but no drive letter - without success.

I have located the USB drive in the Registry (it is OCZ) but cannot delete the Registry key (access denied). I have used usbdeview run as an administrator in both normal and Safe Mode and run Regedit as an administrator but still cannot delete the key.

I am thinking of trying Pstools click here and would like to know if there is anyone on this forum with experience of it, or any other suggestions come to that - I am at the limits of my knowledge on this one.

It's not life threatening as I can use my 8Gb drive on the XP partition and on my Win 7 laptop but I would like to find out how to access it on my Win 7 desktop.

  chub_tor 16:50 12 Nov 2009


  rawprawn 17:16 12 Nov 2009

Yes, I had a 5GB Sony Flash that crashed Windows 7, I tried it on different computers with both XP and Vist and it worked.
I have no idea why it won't work in Win 7, I tried all I know and searched but couldn't find an answer, all my other Flash drives work no problem.
Because it had sensitive financial information on it I destroyed it. I will be very interested to see if there is a solution

  Coff 18:55 12 Nov 2009

Regedit PsExec from click here can often remove stubborn registry keys. It doesn't alter the registry editor in any way, simply opens regedit with higher than normal privileges when you use the Regegedit PsExec shortcut.

Fuller description click here

  chub_tor 19:50 13 Nov 2009

I am marking this as resolved even though it isn't - I have tried every trick in my arsenal as well as many new ones that I have found via Google. I have used Acronis Disk Manager to format, change the volume name and assign a drive letter, all to no avail. I have used psexec to remove registry keys and copy over new ones from my laptop (where the drive works OK) to my desktop. Nothing I have done has allowed the drive to be found and opened in Computer even though it shows up in Device Mnager. I have two other drives that work in Windows7 on my desktop - a 512Mb and a 16Gb - but this 8Gb one just doesn't want to be seen - guess I'll just have to use it exclusively on my laptop.

Thanks for all the advice - if I ever find a solution (apart from a complete reinstallation of Win 7) I will post it on here.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache