REAL help with usb devices...!!!

  arminmckidd 12:51 19 Aug 2009

For reference purposes I am running Windows Vista HP 32bit.
I have been trying to use a number of usb devices in the recent months but they simply have not worked for me, but the device in question, which i believe have caused this problem is the 02 modem dongle. Every single i insert this device, firstly it does not load (no autoplay), that isnt such a big problem but when i check 'My Computer' the device does not appear and when i want to safely remove it from the 'Safely Remove Hardware' icon (bottom-right taskbar)it comes up with 'DiBcom DI9080 based TV tuner device' (which iv never seen before) and 'HUAWEI mobile connect - 3G modem'(this is the 02 dongle drive).
Now iv tried many ways to fix this problem.
Iv tried the uninstalling from 'device manager' (didnt work, it showed the progress bar for about an hour??), i have tried the 'DEVCON' route, but i wasnt sure how to use it, so i might have done more damage to it!?
I have heard that its possible to create a script that will be able to disable/delete the registry keys (or info) about the stored usb devices on the machine, this way every time a new device is entered, its as if you were starting up for the first time!
I would be extremely grateful and of course relived if someone could show me the light in solving this truly annoying problem i have.

Please dont hesitate to ask any further questions if it will help you.

Thank you all in advance.

  Fruit Bat /\0/\ 12:59 19 Aug 2009

click here

be very careful if you are using a USB keyboard or HID keyboard mouse plugged into a USB port.

  arminmckidd 13:10 19 Aug 2009

hello 'Fruit Bat', the machine i am running is a laptop, but my home pc (desktop pc) is also experiencing a similar problem. the link you have it tried and tested?

  arminmckidd 13:50 19 Aug 2009

hey 'Fruit Bat'

I am trying to follow the instructions on the link provided but everytime i try and change the permissions to allow full control for everyone (USB & USBSTOR folders) tells me 'Unable to save changes on USBSTOR ACCESS IS DENIED'???

what do i do?

  Fruit Bat /\0/\ 14:43 19 Aug 2009

You need to be logged in and run the program as an administrator.

  birdface 15:03 19 Aug 2009

Not sure if this is of interest to you.From another thread.

click here

  arminmckidd 15:16 19 Aug 2009

thanks 'buteman' ill give it a go!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017