Raid problem after updating bios

  grommit2009 17:52 20 Aug 2009
Locked

Hi, I recently updated my mb bios as it was very out of date. When I tried to reboot after the update the system would no longer boot into windows.

My system is a home build with 2 150gb raptor hdd in raid 0 config. During POST i noticed that the raid controller was not detecting the array I had previosly been using so I went through F10 to re make the array without selecting 'clean disc' so now during POST the raid array is detected and 'healthy' but I still cannot boot from it. Have tried installing a new hdd and a fresh install of windows to try and access the raid drives but although windows recognises them as one drive I cannot open it, getting an error saying the data is corrupt. Any advice would be very useful as I have tried all I know. I am guessing that I have lost all that was on the two drives and will probably need to re format them. If there is any way to recover them I would much rather do that of course..

Alex

  I am Spartacus 18:18 20 Aug 2009

Some motherboards BIOS allow you to downgrade it. Will yours let you reload the previous one?

I seem to recall that when I ran a RAID configuration on a previous motherboard I lost the RAID array when I upgraded the BIOS and also if I had to simply reset it.

  grommit1923 14:08 27 Aug 2009

Have tried this but hasnt made any difference. Someone suggested using a prog called raid recovery.. However, I cant seem to get either windows or the program to see the two drives. During POST they are listed correctly and reported as 'status ok' but in the bios setup they are only seen if i deselect the nvidia raid option. I have tried going thru F10 during startup and creating a new array (without wiping disc data) but this has also not worked... Having read up more about raid, I am thinking that having created a new array with the two discs I may have wiped out the original array data and therefore will not be able to reconstruct the original... any thoughts anyone?

Alex

  retep888 15:59 27 Aug 2009

After bios update,did you go into bios setup and change the storage controller for SATA to RAID?

Hopefully you didn't delete the array while creating the new array.

  grommit1923 19:28 27 Aug 2009

Yes made sure of that.. I have a nagging thought that by making a new raid 0 array that has wiped any original settings I may have had left on the disc.. I am trying to get my head round how it all works and am confused as to why the two drives are not seen in the bios setup pages.. as I said before they appear in the list of devices during POST and described as 'status ok', but are not there in bios setup... confusing..

Alex

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?