Quick question about my Ethernet LAN

  ade.h 20:31 29 Nov 2005
Locked

Hi all. Can anyone confirm what settings I need to enable to allow a laptop to share a DSL connection on a desktop?

I've got the LAN up and running and all seems okay, but my laptop cannot access the net. Zoom PPP DSL is displayed in Network Connections on the laptop, and its status is connected.

What have I missed?

  mgmcc 22:07 29 Nov 2005

I don't understand from your message which computer is actually connected to the internet. I would have thought it was the desktop but, if that is the case, and you have enabled "Internet Connection Sharing" on the actual internet connection in the "host" PC, the "client" PC (laptop) would get its internet access over the LAN from the "host" - there shouldn't be an entry in the Network Connections folder showing "Zoom PPP DSL" and that it is connected.

  ade.h 15:09 30 Nov 2005

The desktop is connected to the DSL line via an internal modem.

The laptop's connections include, among the usual LAN and WiFi entries, the Zoom PPP DSL connection (Zoom is just the brand of modem). This is exactly waht the connection is called on my desktop PC, so I thought everything was okay.

ICS is enabled on the DSL connection; all three boxes are ticked and the connection is listed as shared. I didn't do so manually, as the wizard appears to have done it. Is this correct?

Why sgould the DSL connection not be listed on my laptop? Is this at the root of the problem?

  ade.h 16:29 30 Nov 2005

I've posted a screenshot click here hope that helps.

  ade.h 22:02 30 Nov 2005

Still not working. I've re-run the wizard on both PCs, the file and printer sharing is working okay, but the net connection is still not being used by the laptop, even though it is listed in the Network folder (see screenshot in previous post).

I thought this might be an easy one to solve and that I'd just missed something fairly obvious.

Thanks to mgmcc for his/her earlier response.

  mgmcc 23:04 30 Nov 2005

If your desktop PC is connected to the internet and you have "shared" that connection, the laptop should get its internet access over the LAN from the desktop PC - it doesn't connect directly to the ISP and it doesn't in any way try to "establish" a connection to the internet, that is done by the "host" PC.

From your screenshot, which I assume to be the Desktop PC, there is no LAN connection to the laptop because the "Wireless Network Connection" isn't connected.

  ade.h 17:46 01 Dec 2005

Sorry, I thought I had said that the screenshot is from my laptop - it relates to the description in my previous post.

Wireless Network Connection is not connected because I do not use any form of Wi-fi network. The desktop has no wi-fi capability, just a Broadcom Gigabit ethernet controller. I am using a crossover ethernet cable instead. The properties box happens to be covering the icon for this connection, but it is connected and working okay apart from the internet access.

As you can see from the image, my laptop sees the DSL connection as a seperate entity. I don't know why this is, as I'm new to this stuff. Thanks for sticking with it.

  ade.h 17:52 01 Dec 2005

click here for an equivalent image of my desktop (host) setup, for comparison.

  mgmcc 18:53 01 Dec 2005

OK, I think I'm getting the picture (excuse the pun!). The fact that the Local Area Connection was hidden behind the open box confused me into thinking there was no active link between the two computers.

Things do then appear to be set up correctly. In the laptop, can you open a Command Prompt window ("Start > Run", type CMD and click OK) and at the promt, type:

IPCONFIG /ALL

and press Enter. Post back the details that are shown for the adapter relating to the Local Area Connection, i.e.

DHCP Enabled - {should be Yes}

Autoconfiguration Enabled - {should be Yes}

IP Address - {should be 192.168.0.xxx} where XXX is between 2 and 254

Subnet Mask - {should be 255.255.255.0}

Default Gateway - {should be 192.168.0.1} - the "Host" PC's IP address

DHCP Server - {should be 192.168.0.1} - the "Host" PC's IP address

DNS Servers - {should be 192.168.0.1} - the "Host" PC's IP address


If you are running any firewall software, it needs to be configured to allow access to the networked computers by entering their IP addresses in the "trusted" area. Also, if running Zone Alarm in the "Host" PC, the Internet Zone Security level must be reduced from High to Medium or Internet Connection Sharing traffic will be blocked.

  ade.h 19:27 01 Dec 2005

Thanks mgmcc, I'll get onto that after I've scoffed dinner. In the meantime, I was wondering about the advanced settings. None of them are ticked by default, but they include stuff like DHCP that you mentioned above. Should any items in that list be selected?

I forgot to mention that I went through the help and support wizard yesterday (useless usually, I know!) and followed its instructions to enter the IP addresses manually. So I think they are set as you describe.

Back later.

  mgmcc 20:15 01 Dec 2005

<<< and followed its instructions to enter the IP addresses manually >>>

You shouldn't be entering the IP addresses manually. When you enable "Internet Connection Sharing" in the "Host" PC, that process automatically configures the Local Area Connection. It will give it the IP address 192.168.0.1

The "client" PC's Local Area Connection should be set to get its IP address automatically and the host PC's DHCP (Dynamic Host Configuration Protocol) server allocates the address in exactly the same way as your ISP allocates an IP address to your internet connection.

<<< I was wondering about the advanced settings >>>

If you mean the Advanced button in the TCP/IP Properties, you shouldn't need to make any changes in there.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

The secrets of creating gory VFX

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache