PS2 Mouse not working

  williamj 14:35 29 Dec 2010

Pointer is static on desktop.
Even in Safe Mode mouse pointer static.
Cannot access Device manager to trouble shoot.

  Fruit Bat /\0/\ 15:04 29 Dec 2010

1. dead mouse
2. broken cable
3. disabled in BIOS (unlikely)
4. blown fuse on motherboard (non replaceable)

a) try another mouse
b) check bios
c) use a usb mouse

Note1 PS2 mice cannot be plugged in or removed while PC switched on without risk of blowing the PS2 fuse on the motherboard
USb mice can be plugged in at any time
Note2 USB legacy for DOS must be enabled in BIOS for USB mouse to work prior to staring windows.

  johndrew 15:13 29 Dec 2010

To move the cursor using the keyboard, press 'Shift+Num Lock' and use the Numeric Pad arrow keys to move the arrow.

You can single or double click by using the Numeric Pad '5' key (once for single, twice for double).

But check your PS2 plug is in the correct socket and fully home. If it is loose then after pushing it home you will need to reboot. Your Device Manager for the Mouse should tell you if it is functioning correctly or not.

Using Safe Mode will not help as the mouse (as with the keyboard) is a prime requirement and uses the same sources to function in either Normal or Safe modes.

  williamj 17:22 29 Dec 2010

Thanks guys,
FruitBat. I have checked 'Legacy USB support is enabled' and install a USB wireless mouse, but the USB mouse does not work either.
Johndrew, Tried your Shift + Num lock to use the number arrows and NO.5 but no luck there either.
The problem started when I dowloaded a program "Chananyzer" to check my wirless strength.
But now with the mouse out of action I cannot uninstall the program or go to a restore point.
By using CTL + Esc I can get my start panel and the normal arrow keys work, but when I get to Add/Remove programs and select the program I want to remove I cannot select/click to remove the program.

  johndrew 09:19 30 Dec 2010

".. I cannot select/click to remove the program."

Pressing <Enter> should act as a 'mouse click'.

  johndrew 09:24 30 Dec 2010

Sorry - I see what you mean.

Have you tried the on-screen keyboard?

  Fruit Bat /\0/\ 15:20 30 Dec 2010

A USB wireless mouse is not going to work as the HID deveice (for the wireless) needs drivers.

A £3 USB cabled mouse should work OK

  williamj 16:15 30 Dec 2010

Thanks again chaps.
FruitBat. You are right about the wireless USB mouse. It would not work either directly to the USB port, or via an adaptor into the PS/2 port.
However I have good news. I borrowed a PS/2 mouse that was working on another P.C. and I now have a working mouse.
Trying the USB mouse threw me in that I thought it should have worked.
The 1st suggestion to "try another mouse" was the obvious choice.
I am now in the process of tidying up the mess I made trying to get the mouse to work.
Thanks again.

  williamj 08:04 31 Dec 2010

johndrew, Now with a mouse that works using the keyboard keys you suggested now also work. Thanks.
The faulty mouse when connected I think was preventing the keyboard keys operating the mouse.
Re tidying up the mess. I had restored the P.C. to the last good boot, and that had wiped all my restore points, and I had difficulty connecting to the internet.
Moral of the story. Don't muck about and make a bad situation worse.
Will mark this question resolved shortly. Leaving open is case you have further comments.

  johndrew 11:53 31 Dec 2010

Perhaps we should have suggested unplugging the mouse and seeing if the keyboard worked as advertised then.

Isn't it great to have these 'wise' ideas after the event!!

  williamj 09:39 01 Jan 2011

johndrew, Yes we are always wiser afterwards, but hopefully learn something a long the way.
And try to remember.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache