Programs not responding

  stlucia2 19:29 15 Feb 2011

A couple of days ago I thought I had an issue with Firefox, and got some help on this forum click here. Since then, I've stopped using Firefox and am using IE7.

But now, some of the issues mentioned in my previous thread still exist. When I try to manually update Avast free, it hangs after a couple of seconds, and eventually reports that it can't connect. Yet my internet connection is working, and Avast seems to be doing automatic updates okay, for it reports that everything is up to date.

Another problem is that other programs, including IE, are hanging quite often, and eventually displaying the "Program not responding" message. When I click on "End now", it takes over 2 minutes for them to shut down.

My OS is Win XP with all updates, and all my hard drives have at least 17Gb free. Full scans with Avast, Spybot S&D, Malawarbytes, and Superantispyware show no infected files.

Any idea what could be causing the sudden increase in programs not responding, please? If it's possibly a nasty that my free software hasn't detected, any suggestions for a better anti-virus?

  iscanut 19:40 15 Feb 2011

How much memory do you have ?

  Fruit Bat /\0/\ 20:01 15 Feb 2011

How much free space on the drive with the page file?

  woodchip 20:02 15 Feb 2011

Why not try running System Restore to a Old Date before changing anything else

  stlucia2 20:23 15 Feb 2011

"How much memory do you have ?" Good question, I don't know. How do I check it?

"How much free space on the drive with the page file?" Which drive has the page file? My C drive is 46.9Gb with 16.9Gb free; my D drive is 20.9Gb with 9.82Gb free; E is 77.9Gb with 18.1Gb free; F is 63Gb with 19.5Gb free; and G is 19.2Gb with 11.0Gb free. C contains Windows and program files; the other drives are for data, documents, photos, music, etc.

woodchip, I've never used System Restore, and haven't knowingly set any restore points. How do I go about checking if there's a restore point. If there is one, what effect does going back have -- does it delete recent programs or data?

  stlucia2 20:25 15 Feb 2011

... this thing where programs fail to respond seems to happen only within the first quarter hour or so of me switching my PC on. This evening, for instance, IE hung when I was accessing my second "Favourite" of the evening. After ending IE and re-starting it, it's been running smoothly, accessing several web sites, for about 90 minutes now.

  woodchip 20:35 15 Feb 2011

It sounds like it may be the PSU taking its time to warm up to full operating Temperature. Could be on its way out, as that is what happens when they start to fail

  stlucia2 20:55 15 Feb 2011

Interesting theory about the PSU. My PC is an HP Pavillion about a year old, so it shouldn't be on the way out.

And the PC is powered down but not switched off from the mains, so isn't the PSU on all the time, so shouldn't need time to warm up?

  woodchip 22:41 15 Feb 2011

PSU is not on all the time but power does go through it. PSU only fully works with a load on it. just low power goes to motherboard from PSU when its switched on but not running. its called a Switching PSU. If no Load connected to it and you switched it on it would blow the PSU

  stlucia2 08:54 16 Feb 2011

Well, this morning I had my usual problem when switching on. This time I took note of what was going on:-

I switched on whilst having my breakfast. After ten minutes I went to the PC and found an Adobe update message, so I clicked to permit it to proceed, and it seemed to just disappear. Hit Ctrl-Alt-Del and saw no processes running.

So then I clicked on IE7, the cursor changed to an egg timer for less than a second, and then reverted to an arrow. No apparent activity from IE7, and Ctrl-Alt-Del showed no processes running. Tried IE7 again, and then Firefox, both with same result. Decided to play a game of Freecell while I waited to see what would happen, and it loaded up instantly, as normal. Then I got a Comodo warning that Adobe was trying to alter a file, which I declined.

Then all of a sudden there's two IE7 buttons and one Firefox button in my taskbar at the bottom of the screen. That's about 3 or 4 minutes after I tried to start them. I closed all except one of the IE7s, and that's what I'm using now for this internet session.

Does all that tie in with your suggestion that the PSU may be on its way out, woodchip, or something more sinister? Should I be trying a better virus scanner than the ones I've already listed?

Oops, I've just got an Avast popup saying that my last (automatic) attempt to update was unsuccessful. Yet, when I open Avast, it says that my system is fully protected.

  JanetO 09:25 16 Feb 2011

Also try last known good configuration; when booting up tap F8.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?