Programs inaccessible

  GPC 21:45 03 Mar 2011
Locked

Completed a scan with Superantispyware. It found an deleted some malware.
Now no icons will work,Outlook Express
All I get is "application not found" from all icons including antivirus software.
Same response from list of programs when going to "Start" and "all programs".
Going to "Explore", "my documents" and clicking on a file, the associaated programme (e.g. MS Word, Excel, etc) opens the file as normal.
Email available only through providor's website.
Email attachments all open by clicking as normal... the relevant programme opens.
The programs are "in there" and functioning but will not launch in the normal way.
No response from System Restore.
Suggestions please.
Thanks
G
Help

  northumbria61 22:33 03 Mar 2011

Try system file checker.....perhaps it will replace the missing files.

start>cmd>sfc /scannow

  lotvic 22:38 03 Mar 2011

Don't have a quick fix, but the icons are just shortcuts to the programs .exe

Have you tried rightclicking on the 'broken' icon shortcut and looking at properties and see where the target is located and also try the 'find target'
it will be these associations that are broken.

You could just go into C:\Program Files and find the .exes and rightclick and create a new shortcut.

  birdface 08:30 04 Mar 2011

Does Superantispyware not give you the oppertunity of enabling the malware that it found as it could have been a false positive.
Or maybe try system restore in safe mode.
I have never used this program before but it gives you a list of what it can repair.

click here

  GPC 22:53 04 Mar 2011

Thanks for all the suggestions but as no icons are working, and going to "all programs" and clicking on the programme in the resulting list give the same result "not available".
This also applies to the superantivirus icon etc.
Clicking on the program in thelist results in a window asking me which program I wish to use.
Tried clicking in (for example) MS Word in that list and got the usual "not available" response.
Frustrating as all the programs are still activated by clicking on a file in "My Documents".
Tried System Restore in Normal and in Safe Mode but no joy. Normal mode produces nothing, Trying in Safe Mode gives a message saying "not protected".
"CMD" in "Run" asked which programme as above.
Gotta to be an answer somewhere!
G

  northumbria61 00:17 05 Mar 2011

Try right click on desktop and select VIEW - make sure the last 2 options are ticked - "Show Desktop Icons" and "Show Desktop Gadgets"

  birdface 11:01 05 Mar 2011

Try Task Manager to see if explorer.exe is working.
Cntrl-alt-delete at the same time should work on the keyboard if it does not open from the Taskbar.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?