Program runs correctly in Windows 7 but not 8.1 (Virtural Acorn)

  RISC OS user 12:56 06 Jan 2014
Locked
Answered

I know this program will not be familiar to many Windows users, but it is a program which has run on all the previous Windows OSs since Windows XP and possibly before that. But Windows 8.1 has really gone to town with the problems it has caused me, see below, can anyone out there help please.

I installed Windows 8.1 when it was released a few months ago and since then have had a problem with Virtual Acorn RiscPC AdjustSA. It is not causing me too much trouble as I now know what and where the problem lies. The problem is how do I stop the problem occurring in the first place?.

I run VA as stated on my Windows 8.1 Laptop, and keep all my bank and password info on my real Risc PC when I wish to update my Banking info I run the program in VRPC and obtain the DATA from the RealRisc PC via the LAN all OK, but if I have some files which are out of date on the VA and download the up to date files from Real RiscPC windows insists on saving them in a different location than expected, not on the HardDisc4 which is in the VirtualAcorn folder on the C Drive but in another location which is also named HardDisc4 this file is located at C drive, User, Allan, Appdata, Local, VirtualStore, ProgramFile, Virtual Acorn, VirtualRiscPC-adjustSA, HardDisc4 and there are the new file which I have brought across from the real Risc PC, and they appear when the VARPC is running to be in the HardDisc4, but if one looks for them there by opening the C drive they do not exist where one would expect to find them. To over come this I manually cut and paste the files to the correct location. If I try to delete files which appear to be in the correct location but in reality are else where I get an Access Violation error. Every time I shut down VARPC windows writes some of the !boot files to the incorrect location which can also cause problems so it appears Windows have some thing wrong, or is it just me!

  RISC OS user 14:30 09 Jan 2014
Answer

I have been advised to Google"appdata local virtualstore". On viewing a few of the search results it looks likely that either my user account or the way I am downloading the files from the real risc pc to the Harddisc4 directory in Adjust-SA which is in a sub directory inside Program Files on the C drive doesn't have sufficient permissions to write to the Program Files directory, or presumably a sub directory inside it, so windows redirects the files to the virtualstore for the user account. I cannot say that I understand any of this and still do not know how to over come my problem, can any one through any light on the subject?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?