Probs With Internet Links

  [email protected]© 21:11 27 Dec 2009

Whenever I choose an internet shortcut from start>favorites an error occurs saying 'there was a problem sending the command to the program'. It also happens when I select a link within an e-mail. How can I fix it please? Using Windows 7 and IE8. Thanks.

  MAJ 21:31 27 Dec 2009

.... ensuring that IE is your default browser, or, following the steps below, cures the problem.

Quit all programs that are running.
Click Start, and then click Run.
Type regsvr32 urlmon.dll, and then click OK.
When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK.
If this does not resolve the problem, repeat steps 2 through 4 for each of the following files (in step 3, replace Urlmon.dll with each of the file names below):

  [email protected]© 21:45 27 Dec 2009

The first one didn't work and when I tried the others they all came up with errors.

  MAJ 21:52 27 Dec 2009

What were the errors that came up?

  [email protected]© 21:54 27 Dec 2009

The module Actxprxy.dll was loaded but the call to the DllRegisterServer failed with error code 0x80070005 and says this for all of them.

  MAJ 22:03 27 Dec 2009

Try running the regsvr32 urlmon.dll and the rest from a command prompt, but right click on the Command Prompt at the top of the Start Menu and choose "Run As Administrator".

  [email protected]© 22:07 27 Dec 2009

Sorry thats lost me 'but right click on the Command Prompt at the top of the Start Menu and choose "Run As Administrator".

  MAJ 22:09 27 Dec 2009

If you can't easily find the Command Prompt, it'll be in Start > All Programs > Accessories > System Tools. At least it is in Vista which I'm using at the moment, I suspect 7 will be similar.

  [email protected]© 22:09 27 Dec 2009

Still the same errors.

  MAJ 22:21 27 Dec 2009

Did you "Run As Administrator"? If so, then I'm stumped, [email protected]©

  gigagiggles 07:01 28 Dec 2009

a yahoo search of error code came up with this:

"Possible Remedies:

* Check that you have local administration rights.
* If you are a local administrator (i.e. a member of the ‘Administrators’ group on the workstation) then most likely someone or some application has modified (intentionally or unintentionally) the permissions on one or more registry keys and that this is preventing access. (Alternately, it may be that the key that is failing is one that normally only ‘system’ can update.) To identify which registry key is causing the problem use Regmon (a freeware tool published by System Internals). Use Regmon to capture all registry access when regsvr32 is run. If an ‘OpenKey’ request fails with ‘Access Denied’ (which is listed by Regmon as ‘ACCDENIED’) then run regedt32 and check the permissions on that registry key. If necessary change the permissions on the key to grant local Administrators ‘Full Control’. Then try registering the COM object again. The only times I have encountered this problem it affected more than one key, so be prepared to repeat this process."

it does read overly technical. :-)

when you click start, is "run" immediately available? if not, click "all programs" then "accessories". "run" ought to be available there.
otherwise, search for "cmd".

from "run", type in cmd, then press ctrl+shift+enter.


from the found cmd, right click and run as administrator.

if successful, a command console window will open, along with administrator privileges.

follow MAJ's 'usually' post's instructions.

good luck!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?