Problems with with windows updates

  hiwatt 12:02 31 Jul 2008
Locked

Hi folks,I am not able to search manually for windows updates.I get the small red x and error number 0X80070002.I've tried all the suggestions I can find(emptying the data store folder etc)to no avail.I am worried I don't have all the updates I need but can't visit microsofts update page.A few months ago I had to do a partial reinstall of windows due to a crash and at the time had loads of updates including vista service pack 1,now when I click on installed updates it only shows 63 updates with no sign of SP1.I can check for updates from within the computer and it tells me I'm up to date.I downloaded and ran belarc advisor and that tells me I'm missing one critical update,KB931906 and the earliest update installed is on 09/07/08 but there were lots more installed before then.I would appreciate any help in resolving this problem please.Thankyou

  ambra4 12:30 31 Jul 2008

Download this program Dial-a-fix v0.60.0.24

click here

Unzip and Double Click on the exe file

Click the green tick button click GO

  hiwatt 12:33 31 Jul 2008

It's saying that it's not ready for vista yet?Thankyou.

  ambra4 13:03 31 Jul 2008
  hiwatt 13:17 31 Jul 2008

Thanks ambra.I dont have the windows side bar set to run at start up,I don't use it.I've also searched google with the error number and tried all the suggestions to no avail.Even microsoft can't seem to get it it sorted.I'm not sure what to do next.It's just a bit annoying not being able to search for updates.Thanks anyway.

  birdface 13:28 31 Jul 2008

Might help.click here

  hiwatt 13:52 31 Jul 2008

Thanks buteman but I've already tried that too.Very frustrating.

  birdface 14:08 31 Jul 2008

Yes there was another tool just like dial a fix that would sort the updates out,But cannot remember the name of it.I hope you manage to get it sorted.

  birdface 15:44 31 Jul 2008

Sorry mate managed to track it down but like the other one not for Vista. click here

  birdface 15:57 31 Jul 2008

I don't suppose this is any good.click here

  hiwatt 11:46 01 Aug 2008

Thanks buteman.It searches for updates then says the update does not apply to my system?I downloaded the correct one.32 bit.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse's new logo: the trainer brand looks to its heritage for a fresh identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?