Problems opening microsoft publisher files

  Ant two 16:48 25 Aug 2009
Locked

I am having problems opening some publisher files on both my computers. I'm running publisher 2007 on both machines, one of which is a pc running windows xp, the other is a laptop running vista. Both machines are kept fully updated and the problem started at the same time on both machines.
I've got about 20 publisher files which all used to open ok but now some of them will not. It's not always the same ones which will not open and sometimes a file which has recently been opened will fail next time.
The only message I'm getting is "publisher cannot open this file"
My initial suspicion is an update to publisher may have caused a conflict with another program so I'm wondering if anyone else is experiencing similar problems.

  GaT7 17:53 25 Aug 2009

You may require this hotfix to correct the problem:

From click here:

"This hotfix fixes the following issue:

After you apply 2007 Microsoft Office Suite Service Pack 2, you receive the following error message when you open a file in Publisher 2007:

Publisher cannot open this file Error 1100009."

Hope it works for you. G

  Ant two 17:49 26 Aug 2009

Hi Crossbow 7, I've tried applying the hotfix on the xp machine but it has made no difference.
Thanks for the advice though.

  GaT7 18:35 26 Aug 2009

Similar problem here click here, with the only thing that works being to uninstall the update that seemingly caused it in the first place! G

  Ant two 19:39 26 Aug 2009

Guess at least I know I'm not the only one with the problem now!
Must say I'm a bit reluctant to uninstall sp2. Does any one know what the security issues are by doing so?

  GaT7 19:47 26 Aug 2009

Many improvements with SP2 as well, all of which can be found at click here.

Uninstall it temporarily only, i.e. until MS come out with a better fix.

Why don't you revisit click here & submit feedback at the bottom that the hotfix didn't work for you, etc. G

  Ant two 20:20 26 Aug 2009

Yes, good idea. I'll try uninstalling tomorrow then leave feedback.

  Ant two 21:08 27 Aug 2009

Hi again, I've tried to uninstall sp2 but to no avail, it reports it is not removable. I've looked back through system restore which goes back as far as 14th May but can find no reference to sp2. I've seen reference on this forum to sp2 downloading as long ago as April and as I've got auto-update enabled I guess mine was updated around then.
I've removed all other updates which refer to publisher or office in general except KB967642 which also reports it is not removable. Any other ideas?

  GaT7 21:15 27 Aug 2009

Hmm, I see what you mean.

If you have the original install disk(s), you could uninstall Publisher/the lot & reinstall it/them? Then perhaps postpone installing the SP2 update for some time. G

  Ant two 21:29 27 Aug 2009

Just had one of those eureka moments! I didn't see the hotfix you first suggested in the list of updates. Just been through the process again and all is ok. Thanks for all your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How secure is your Wi-Fi?

AMD vs Intel: we put the most powerful desktops for designers and artists head-to-head

iPhone tips & tricks

Les meilleurs ordinateurs portables 2017