Problems with M/B USBs

  Catastrophe 12:39 25 Jan 2009

Apart from the back panel USBs I have front panel USBs connected to a back panel USB and rear mounted USBs (not PCI)connected to M/B headers.

Mouse (USB) stopped working and I changed it to PS2 / USB adapter and it worked again.

Trying other USB devices ... mem sticks, card reader etc., failed to work. I put in an old PCI USB card and that works with all USB devices.

It may be entirely disconnected (loose connection?) but I have 2 SATA disks here and sometimes 0, 1 or 2 show.

Any ideas please?

  DieSse 13:10 25 Jan 2009

I used to have intermittent with an internal card reader connected to a motherboard header. Sometimes it was there sometimes not. when it wasn't, the quick solution was to take the connector off the header and put it back on again.

Eventually, with the system switched off, I dribbled a little alcohol into the plug (not the header) and pushed the plug onto and off the header a number of times. Let it dry out well before switching back on.

Since then it hasn't happened again - so I suggest bad connections are possibly the issue. It's very easy to get a thin film of contamination on plugs/sockets over time.

  Catastrophe 14:22 25 Jan 2009


Many thanks for that. I will try that shortly. Meanwhile I believe the SATA aspect is solved. I will describe what happened in case it helps someone else with a similar problem.

On booting PC went through memory check and recognised IDE boot drive and optical but not SATA(s). I then got a very faint Windows screen but with no movement. This remained for a long time. I tried the monitor on a different PC and, after a fraction of a second faint screen it continued as normal.

Reconnected first PC and noticed one lead was disconnected on SATA PCI. On examining the SATA connection on the card it showed prongs, not the usual bit with the L shape. I removed PCI card and rebooted to find Windows loaded perfectly. Still the same USB problem so I will try DieSse's suggestion.

The SATA mystery is that both drives had been shown. I searched inside case with strong portable light (especially along ridge). Now there must be a small piece missing that I cannot see in the case. Weird!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

11 best portfolio websites for designers and artists

Office for Mac buying guide: Price, Office 2017 rumours & new features

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?