problems loading a cd into drive e

  jcart 15:08 11 Apr 2015

I have a Dell Inspiration 530 Running Windows 7 Home Premium When I try to open a cd in drive E, I get a message saying, “Insert disk “; “Insert disk into drive E” I’ve run a check and it shows the driver is up to date. I’ve run a MS fixit program and it shows everything is good except it cannot detect a disk. I’ve uninstalled and reinstalled drive E and nothing helps. Does anyone have any suggestions? Thanks in advance, J. Cartwright [email protected]

  Fruit Bat /\0/\ 15:21 11 Apr 2015
  1. bad disk - your player cannot read this type of disk or the disk is damaged - try another disk

  2. there are bad connections to the drive - the data cable may be faulty or slightly loose at the rear of the drive or where it connects to the motherboard - - make sure the cable is fully pressed into its connections at either end and or swap the cable.

  3. the laser or laser guidance on the drive has failed - a new drive will be required. New drives are less than twenty pounds.

  robin_x 15:33 11 Apr 2015

Also see if DVD can be seen instead of CD

You can find Chipset and Drive drivers (and Firmware) on Dell Support page but I think above suggestions are more likely

  jcart 19:01 11 Apr 2015

Thanks for the suggestions. I tried a sony DVD+RW disk and auto play opened right up. I then tried several CD's and it would not recognize any of them. I had backed up files to CD's 2 weeks ago with no problem. (I checked this they were CD's) I believe it is time for a new drive.

Thanks again for your suggestions.

  Fruit Bat /\0/\ 19:24 11 Apr 2015

DVDs and CD use a different laser in the drive

if one is OK and the other not

then agree its time for a new drive.

cheap enough and 4 screws, 2 cables easy enough to fit.

  bumpkin 19:28 11 Apr 2015

Jcart, Go for a new one, once they start playing up you will have endless hassle with it. In my experience some can last for years while others are short lived. Fortunately they are cheap, in fact I ordered a new one yesterday for myself.

  robin_x 20:21 11 Apr 2015


It may be worth checking chipset driver from Acer site quickly.

It will only take 5 mins and a reboot.

5 years ago, my optical drive (on old PC) half stopped working when I upgraded it from XP to W7.

I tried everything, including Fixits and Upper/Lower filters etc.

I gave up, assuming laser was duff, and since I already had an external drive as well.

Only the other week, I stumbled on a single report on, some American thread, saying "Same problem. All solutions tried. Manufacturers' Chipset driver fixed it"

I'm intrigued if it could be the case in some instances.

  bumpkin 22:05 11 Apr 2015

jcart, robin gives good advice so by all means try it but you can get a new one for next to nothing and simple to fit in a desktop, problem solved.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?