Problems with Kaspersky Installation

  ykzn 08:33 25 Jun 2008

Hi all!

Please help me out with this issue.

I recently tried to install Kaspersky Anti-Virus 7.0 onto my PC and the installation was interrupted before completion.

Then, I tried to install it again but the following message prompted up:

"You must restart your computer before proceeding with the installation"

I am left with no choice but to choose "OK".

Even after I have restarted, I still couldn't install it because this message still pops up!

Now, please, all suggestions are welcome!


  mike40 09:16 25 Jun 2008

Hi ykzn

I had a similar problem when I tried to update to the new version. The un-install routine did not completely remove the old version and the system froze. after waiting a while I re-booted but it would not install Kaspersky giving me the same message as you are getting. I did a search for Kaspersky and found it still existed in program files. I deleted all references to it and the installation them completed OK. Create a system restore point before you try this

I also deleted all references to it in the registry but I am not sure this is necessary

Hope it works

  birdface 10:58 25 Jun 2008

Try Revo here

  Poitier 11:29 25 Jun 2008

I do not know if this is the problem but before installing KAV7 it is essential to ensure that any previos anti virus programs are completly removed and that no other firewall apart from the windows one is installed. Kav7 is not compatible with other firewalls.

  ykzn 05:25 02 Jul 2008

Hi all!

Sorry for my very late reply. I was trying out what you suggested me.

I acquired and installed Revo Uninstaller but when I ran it, Kaspersky didn't show up in the list of programs that can be uninstalled.

Again, when I tried to install Kaspersky, I still can't because the same message popped up.

So, how do I manually clear the registry? Can anyone tell me please?


  ykzn 06:03 02 Jul 2008

Please, everyone, I really need help with this issue. Each and every suggestion is welcome.


  brundle 06:12 02 Jul 2008
  ykzn 04:31 03 Jul 2008

Hi All!

First of all let me thank all of you: Mike40, buteman, Poitier and brundle for all your kind help! Thanks guys(or gals or both)!

Now this issue was solved after I tried the link that brundle referred me to. It is here: click here

Thanks again to everyone who tried to helped me!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?