Problems with Java update - to

  tallboy 11:46 06 Oct 2009

My AMD Athlon 1.4GHz Mesh PC running Windows VP currently has Java installed. I use the FileHippo service to keep me informed of new updates and it tells me that the latest Java version is

Having downloaded it, I tried to install it and got error message ' The feature you are trying to install is on a Network Resource that is unavailable. Click OK to try again or enter an alternative path to a folder containing the installation package jre1.6.0_13-c.msi'

I couldn't locate this package on my PC but I did so on the web. I then tried to re-install Java and got a further error message - Error 1714. 'The older version of Java 6 Update 16 cannot be removed.'

I then tried to completely remove Java (it no longer showed up in the installed s/w list) and tried to install jre-6u16-windows-i586.exe, which I believe to be the correct exe file to install the current version of Java. I then got a further error message telling me that Java 6 update 16 cannot be removed.

How do I successfully upate from version to (Fortunately before starting the update I created a Restore Point and hence was able to go back to a working version of

All suggestions welcome.

Thanks, Tallboy

  Kevscar1 12:11 06 Oct 2009

Try doing it from the Java site

click here

  provider 2 12:46 06 Oct 2009

Top 15 Java issues from the same site: click here

  tallboy 13:45 06 Oct 2009

Thanks for the prompt responses Kevscar and provider 2.

I went to the Java website and tried to load the update again (having first created a Restore Point.) Alas it failed again on two counts.

First it said the old file bin\awt.dll was not found and hence could not be updated. It then came up with Error 1722 'There is a problem with this Windows Installer Package. A program run as part of the set up did not finish as expected'

Before running the update I didn't try removing Java. Is this worth trying and also using the Windows Installer clean-up utility to remove it?

  mfletch 13:53 06 Oct 2009

Its been a common problem.

Go to start>computer>C/drive>program files

Right click and delete the java file {folder}

Install the latest version

  Ventad 14:11 06 Oct 2009

And if you cannot delete it like mfletch says go to :-Task Manager/Processes tab/ right click jushed.exe and click 'end process' then try again.

  tallboy 16:51 06 Oct 2009

Thanks for the suggestions mfletch & ventad. I eventually fixed the problem (after using the Microsoft Installer Cleanaup Utility and three different Registry Cleaners) by using the offline version of Java. i.e. jre-6u16-windows-i586-s.exe

The online version came up with installation errors - even though my Firewall and AV were turned off at the time.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Graphic tees: 14 best websites to find your next T-shirt

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017