Problems with "Hide Inactive icons" in XP taskbar

  akpak 13:20 20 Feb 2004
Locked

I'm having problems with "Hide Inactive Icons" in the XP taskbar. I'd just installed an updated sound driver (Realtek), and then clicked on the Sound Manager icon in the notification area to check the settings. To do this I had to click on the arrow to show the hidden icons, but when the Sound Manager opened the arrow disappeared and became a sort of blank square, and the SM icon slid out of sight.

There was nothing I could do to expand the icon section again to see the hidden icons, so I restarted, which brought the icons back. However, the taskbar now looked as it would with the "Hide Inactive Icons" option unticked (even though it was still ticked), and there was no way I could get it to work properly again.

I think the installation of the sound driver was coincidental, but to be on the safe side I rolled back to the previous driver and restored the system to a point before I put the new driver on. This restored the taskbar to its previous look (with hidden icons and an arrow), but as soon as I clicked on the Sound Manager icon, everything went wrong again.

I've spent ages on the phone to technical support, and they got me to do all sorts of things, including reinstalling all the original media drivers and a System Restore, but to no effect. I'm now being told that there must be a glitch in the registry, and the only way to remedy the problem would be to completely reinstall Windows.

The only thing I can think of that I had changed recently was to disable Messenger Service and block it with the Norton Internet Security firewall - in both cases following instructions on the MS (KB330904) and Symantec (2003062611142036) sites.

Does anyone know what might have gone wrong, whether it will have affected anything else on the computer, and if it can be fixed without reinstalling Windows, please?

  vulcanian 13:45 20 Feb 2004

You could try deleting the icons.
Look here click here

  akpak 16:02 20 Feb 2004

Thanks, but I'm not at all keen on doing anything in the registry, as I'm by no means an expert. (And Tech Support have advised against it.) Is there another way?

  jim1947 16:07 20 Feb 2004

It sounds like it has "refreshed" the icons, and it may take a while for them to become inactive again. Just leave them for a while to see if they disappear.

  Djohn 16:10 20 Feb 2004

Have you tried right clicking the taskbar and choosing properties? Click on Customise then highlight each Icon in turn. When you highlight an Icon you will see a window to the right of same with a drop-down menu. From this menu you can tick as follows.

Always show

Always Hide

Hide when inactive

Set each one as you want them, click on apply the OK and see if this will sort the problem for you. j.

  Djohn 16:12 20 Feb 2004

As jim1947 says, it will take a while for the "Hide when inactive" ones to disappear. j.

  akpak 20:01 20 Feb 2004

Thanks for the suggestions - I've tried right-clicking the taskbar etc. And it's not that I need to wait for the icons to go away in their own time, the problem is that I can't get the "Hide Inactive Icons" option to work at all. Even if I tick that box, the notification area stays large, and the circle with the arrow doesn't come back. It just seems to have lost this feature altogether.

  Djohn 20:37 20 Feb 2004

akpak, this happened to my friends PC after a format and install of windows. He left it running for several hours that day and still the chevron wouldn't appear and on booting up the following morning still the same. Then after approximately 4 hours it appeared, Icons were hidden and it worked fine from then on. Stick with it for a few days, I have a feeling it will start to work. j.

  ©®@$? 20:43 20 Feb 2004

the best thing to do is take the tick out of hide inactive icons, then re-enable it..then change some of the icons to show, and some to hide, change the ones that are in use to hide..then hopefully the little arrow will appear

  ©®@$? 20:45 20 Feb 2004

i mean take the tick out of hide inactive icons,then apply the tick it and apply,

  akpak 11:08 21 Feb 2004

I had already tried unticking and reticking the option, but that didn't work. I'll try some of the other things suggested, but if it takes a few days you may not hear any more from me till then.

However, if solving it turns out to be complicated and it seems unlikely to have caused any other problems, I may just decide to live with it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans échec ?