Problems with Firefox 3 and Flock 2

  HannibalCat 14:59 19 Jul 2008
Locked

Exactly the same problems have occurred with both these browsers - I download and install them, use them fine for one session then my internet connection seems to be lost even though I still have an extant address and every program on my PC slows to a crawl. I have had to remove both browsers and go back to a system restore point from before their installation, then turn PC and modem off before everything works again. Flock 1.2.4 is okay, as is Opera 9.5. Also, when using Firefox 3 and Flock 2 an immense amount of hard disk accessing seems to go on.
I don't know if this is something conflicting with a windows update - I have an AMD processor so I don't think SP3 downloaded - but it is very perplexing.

  MsTechie 19:42 19 Jul 2008

Sorry, are you saying you have installed SP3, if this is the case then this could be the root of your problems, the exact same thing happened to me after this install (SP3), once removed everything was ok.

  So Afraid 19:56 19 Jul 2008

I have just uninstalled Firefox 3 and gone back to version 2,because i had the same hard drive activity and bandwidth was being used as if i was downloading files,no problems back with firefox 2.

  MsTechie 20:01 19 Jul 2008

Should have added that I too went back to Firefox 2, with v3 my cpu and memory usage went up by 50%, glad to hear I'm not the only one.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?