Problems connecting to Belkin Wireless Network

  DHutchison 16:18 20 Oct 2007
Locked

Hi,

I'm having some problems getting my desktop PC to establish a wireless connection. I have a Belkin Wireless G router and network adaptor, and am running Windows XP.

Here's the thing: When windows starts, the connection is very rarely established automatically. The wireless icon in the system tray is coloured red, and hovering the mouse over it indicates that it is 'Scanning...'

Sometimes, right-clicking on the network icon in the system tray, then clicking 'Repair' will get things up and running, but the process will usually stop at the 'Connecting to wireless network' stage, with the outcome being that the PC was 'unable to connect to the wireless network'. But it does work every now and again.

Very occasionally, right clicking the wireless icon and clicking 'Disable Windows Zero Configuration (WZC)' seems to help make a connection. At other times, enabling this option seems to do it. Usually, neither do anything.

If and when a connection IS made, signal strength is seen to be 'Very Good' or 'Excellent', which makes it seem unlikely that the the problem is due to a weak signal. And once it's connected, it tends to stay connected.

I've tried reinstalling both the router and adaptor, but the situation remains much the same. There are no more recent drivers than what are on the installation CDs, it seems.

I'd be EXTREMELY grateful if anyone could think of any ideas that might make the connection happen automatically every time?

Thanks!

  brundle 18:14 20 Oct 2007

USB adaptor?
Are you using Belkin's software to manage the wireless connection? If you are and are happy with the way it works, disable "Windows Zero Configuration" entirely.

Otherwise disable or uninstall the Belkin software (not the device driver of course) and stick to the Windows software.

To make sure WZC is disabled, go to start menu/run, type

services.msc

press return

Scroll down to Wireless Zero Config, make sure it is set to Disabled and stopped. Conversely, if you are ditching the Belkin software, make sure it is set to Automatic and Started.

  dms05 15:22 21 Oct 2007

Quote 'right clicking the wireless icon and clicking 'Disable Windows Zero Configuration (WZC)' seems to help make a connection. At other times, enabling this option seems to do it.'

Brundle explains the reason. Either use one or the other but never both. Most people use the Windows Zero Configuration and it seems to cause the least problems.

  mikesuther 14:07 24 Oct 2007

Hi, The way i configured my setup was very simple. firstly I uninstalled the Belkin programs now initially i connted to the router via lan cable that came with router. I then congiured the router by going to the web address for the router in IE. Normally this is 192.168.0.1 or what ever the belkin instructions say. make sure and setup security encryption either wep or wap and make a note of these details.

once you have saved the settings remove the lan cable and click the wireless icon and select search for networks. the pc should then look for networks, when you find the one you have setup click to connect it will then say type in password which will be the wep or wap code which is normally a mixture of capital letters and numbers.
once you have connected every time you start your pc will look for the wireless setup and will automatically which is what i am able to do. As i say i rely 100% on the windows network controls.
I hope this helps

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017