Problems with Camcorder and vista?

  BurghBhoy 21:04 11 Mar 2010
Locked

I have plugged my Sony camcorder into my new laptop and after trying to install device driver software(recommended) it's telling me Windows cannot find device software for my device?
The Camera worked fine on my old laptop with windows XP?
Any advice much appreciated!

  awest3 21:31 11 Mar 2010

Hi, I had a similar problem with my Sony camcorder, it worked perfectly on my XP machine but not on my Vista machine. It was quite a while before I realised that the firewire card had a version of the iee1394 driver which did not support Vista (my assumption because they should be backwards compatible). Neither Sony or Adobe (I use Adobe Premiere elements 4) were any help both blaming the other. I eventually got an older copy of the driver and lo and behold everything works as it should.

All I did was right click on my computer (from desktop), click on properties, click on device manager, click the plus sign to the left of 'ieee1394 bus host controllers', this should bring up your controller, double click on it, click on the driver tab - this will show you the controller version, mine is 6.0.6001.18000. If the 'Roll back driver' button is available (if no previous driver is loaded on your PC i.e. greyed out) click on it to roll back the driver. If you cannot rollback then you will need to download a driver from one of the various internet sites which provide them....the version above works for me..

Apologies if you already knew all this...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?