Problems With 512mb Kingston USB Flash Drive

  Poloman69™ 20:20 25 Sep 2005

I have a USB flash drive which has got me puzzled ???????

The thing is that on my friends & families pc it works absolutely fine. However when it comes to my pc it doesn't.

My onboard USB ports work fine as my scanner, printer, digital camera's which are connected all work fine.

* I checked the drivers = FINE
* Tried the other USB port - No difference
* Ran the add hardware wizard = FINE (nothing
new found)
* Tried disconnecting the other devices and
having the USB drive as standalone - Nothing

I just find it weird that ever other device works fine, yet this one won't.

I do unfortunately have USB 1.1 onboard, and the Flash drive is USB 2.0, but the other devices i have tried connecting via USB which are USB 2.0 work, yet this one won't.

It also doesn't work with other USB flash drives i have got friends to try.

BUT...... I works fine on other pc's and not mine.

Model - Kingston 512mb USB 2.0
2 USB Ports availalbe onboard
OS - Windows XP - 768mb Memory

Any ideas ?

  dcu11 20:25 25 Sep 2005

so your pc doesn't recognise any flash drive? sounds like a problem with the generic drivers windows uses when you insert a drive but this usually happens unprompted, "behind the scenes" so I'm not sure how you could address it

  MAJ 20:26 25 Sep 2005

While it's true that USB2 devices usually are backward compatible with USB1.1 ports, unfortunately it's not true all the time, Poloman69™, sometimes some USB2 devices just wont work on USB1.1 Having said that, you could try shutting down the computer, attaching the Flash Drive to your USB port and starting your computer again, sometimes they will work when you connect them that way, rather than connecting them when the computer is already switched on.

  Poloman69™ 20:26 25 Sep 2005

The thing is, is that it used to, but for some reason it doesn't anymore. The USB flash drive works fine elsewhere. but not on mine????

  MAJ 20:39 25 Sep 2005

Not sure if you've tried my suggestion or not, Poloman69™.

  Fruit Bat /\0/\ 20:42 25 Sep 2005


Start - run - type services.msc press enter


Plug and Play is started

Removable Storage is set to manual

Smart Card is started

To start Highlight the item right click select properties in startup type change to Automatic
Click start button click ok

exit services and retry

  Poloman69™ 20:50 25 Sep 2005

Already tried that and nothing different

  Poloman69™ 21:27 25 Sep 2005

I tried looking at kingstons site, but no luck.

I have looked at other searchs for USB drives and they mention about drive signing. The USB Flash normally shows up as the 'G' drive.

Do you think this could have anything to do with it, or a flaw with microsoft?

p.s. I have SP2 already installed

  jimv7 23:38 25 Sep 2005

Is your psu supplying enough power to run the pen drive, disconnect all other usb and try it on its own.

  Poloman69™ 19:54 28 Sep 2005

Tried that already, sorry, should have posted that too.

Thought that its to do with drive letters, so connected just the optical DVD-RW & hard drive up, and still doesn't work

Thought problems with drivers - they're all up to date & working fine

Thought problems with drive itself, but that fine in other pc's

Still no idea.

I tried looking at other similar postings but no luck there either


  grumpygramp 20:07 28 Sep 2005

I have a Bytestor pen Drive which will only work in my USB 2 Ports .It will not work in my USB 1 ports . AS I have both it no problem. Could yours be the Same?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?