Problem with USB Pen Drive

  AndyMc 18:56 16 May 2005

I have had a USB pen drive for several months but it is now no longer working correctly. When i plug it in and try to access it using My Computer i get the message 'Please insert a disk into Drive F'. Has anyone else had this problem with their pen drive or is mine just broken?

  walesrob 19:05 16 May 2005

Ok, a little more information about system specs will be a help here.
Other drives Cd/DVD?

Post back and we'll be able to help you....

  AndyMc 19:09 16 May 2005

I'm running Windows XP, 512MB RAM. I have DVD RW and DVD ROM drives. Anything you need to know?

  Jackcoms 21:26 16 May 2005

How do you remove the pen drive when you've finished using it?

You should right click on its icon in My Computer and left click on Eject.

If you have been simply pulling it out of the USB port, there may have been some damage to it over time.

  walesrob 00:02 17 May 2005

'Please insert a disk into Drive F'

Now this bit confuses me. I use pen drives as well and I've never seen an error message like this before. Have you tried plugging the device into other usb ports? Have you made an major changes to system configuration recently - this may result in drive letters getting messed up. By any chance is your motherboard a PCChips?

As for Jackcoms comment "If you have been simply pulling it out of the USB port, there may have been some damage to it over time.
" NOT true - Win XP allows write caching and quick removal, unlike Win 2K. This is a per user setting for each USB removable device.

  bretsky 00:41 17 May 2005

Maybe but not likely click here

bretsky ;0)

  AndyMc 16:30 17 May 2005

Thanks for the responses but I haven't made any major changes to the system configuration recently and my motherboard isn't a PCChips. I have tried the pen drive in 3 other PCs and get the same message. The strange thing is that when you run an an anti-virus scan on the drive using Norton it picks up that there are 93 files on the pen drive.

  Indigo 1 16:45 17 May 2005

Is this any good to you ?

click here

  freaky 18:08 17 May 2005

You say it has worked OK for several months, in view of this I would suggest that it has just decided to retire!! Alternately it needs a defrag.

  walesrob 20:18 17 May 2005

Seems the fault you describe is not uncommon, but try this AT YOUR OWN RISK!!:

For USB flash drive that asks for a disk to be inserted try the following in Win2000 or WinXP:

1) Right click on the "My Computer" icon on the desktop> select MANAGE.

2)Select Disk management from the list on the left hand part of new window.

3) Find your device listed on the right side.

4) Try creating a partition if none exists and then format with FAT. If a partition already exists you can try deleting it and recreating & formatting it.

I'll keep looking for a solution, but after googling this most forums state that cheap USB sticks are not that reliable.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Musique en streaming : Spotify vs Deezer