Problem Setup W98 & ADSL Router..

  daba 21:43 22 May 2005

I am having troubles setting up my W98SE PC to talk to a D-Link Wireless ADSL Router.

Here's the existing set-up.

PC connected to router via CAT5. Nothing else connected yet. (Existing USB Sagem modem allows internet connection). Router green light on CAT5 port.

Control Panel->Network has an abundance of entries:-

1. Client for Microsoft Networks - This is setup as : Do Not "logon to Windows NT Domain", and option "Logon and restore network connections". The Primary Network Logon is set to "Client for Microsoft Networks"

2. Dial-Up adaptor : Bound to "TCP/IP-> Dial-Up Adapter"

3. Edisonsoft ES-620 USB Infrared Adapter : Bound to "Fast InfraRed Protocol"

4. Edisonsoft ES-620 USB Infrared Adapter : Bound to "Fast InfraRed Protocol"

5. Edisonsoft ES-620 USB Infrared Adapter : Bound to "Fast InfraRed Protocol"

6. Edisonsoft ES-620 USB Infrared Adapter : Bound to "Fast InfraRed Protocol"

[why there are four of these is a mystery to me, unless one gets installed for each USB port that the IR dongle has been plugged into]

7. Microsoft TV/Video Connection : Bound to "TCP/IP Microsoft TV/Video Connection"

8. SiS 900 PCI Fast Ethernet Adapter : Bound to "TCP/IP-> SiS 900 PCI Fast Ethernet Adapter"

9. USB ADSL WAN Adapter : Bound to "NDISWAN-> USB ADSL WAN Adapter" - This is the current Internet connection.

Protocols listed are :-

1. Fast Infrered Protocol


3. TCP/IP-> Dial-Up Adapter

4. TCP/IP Microsoft TV/Video Connection

5. File and Printer Sharing for Microsoft Networks.

Can I get rid of some of these devices and protocols ?

I don't seem to be able to get W98 to talk on the ethernet, it is supposed to get an IP address from the Router via DHCP, but I can't even Ping the router {} I have tried both "Obtain an IP Address...", and static IP, neither worked.

I'm sure I've missed something obvious, but can't see the wood etc....


  woodchip 21:51 22 May 2005

Is it a Router Modem combined?

  daba 21:57 22 May 2005

D-Link DSL-G604T

- 54MBps 2.4GHz Wireless Access Point

- Built-In 4-port Fast Ethernet Switch

- Built-In ADSL Modem/Router

- 54Mbps USB Dongle

I'm intending to use the USB wireless dongle for the lad's PC to share internet access, and my printer. (Salesman told me it would work as a LAN switch as well as an ADSL sharing device).

  woodchip 22:04 22 May 2005

Then you need to remove all the items in Networking except TCP/IP Remove USB modem from Add Remove and Remove USB modem from Device Manager. You should have a Onboard Ethernet or a PCI Ethernet card fitted, you should only have one Ethernet listed in Device Manager if there is a Onboard that you do not use Disable in Device Manager or in BIOS. Restart comp You should then be able to access the Router Setup in Internet Explorer with the Number you said

  daba 22:24 22 May 2005

Ethernet port is On-board the mobo, stacked above the USB ports. this is the only physical ethernet port.

In device manager, there is only one ethernet device listed, the SiS 900.

There shouldn't be a problem with the USB WAN adaptor listed under "Network" in CP as it's not ethernet related.

The basic problem is getting Windows to DHCP from the router, i believe.

Is this problem related to Windows Logon? i.e. how does Windows know to get an IP address from the router? I've always been standalone on this PC, and have never used (and so disabled) the logon dialog. My guess is I need a lesson in networking setup....

  daba 22:37 22 May 2005

... once I know I can communicate with router, then I can remove USB modem to set up the Internet connection.

If this gets removed, and if I can't use the D-Link, the only way I can put it back is with a SCANREG /RESTORE. The Sagem set-up doesn't seem to be successful in doing this, as a 57-minute call to Tiscali helpdesk was required to get me back on the web.

  mgmcc 23:47 22 May 2005

You do not appear to have a "TCP/IP" protocol entry relating specifically to the ethernet adapter. You have entries for the Dialup adapter and the TV/Video adapter, but not the ethernet one.

  daba 00:05 23 May 2005

You are quite correct - but I just checked back in CP

Protocol:- "TCP/IP-> SiS 900 PCI Fast Ethernet Adapter" does exist !

How convinced am I it wasn't there when I originally posted ?? Curious

Anyway, I'll reset IP settings to "Obtain..." and reboot, (had to do a scanreg /restore that put it back to static), and post back...

  woodchip 12:59 23 May 2005

You will not get it to work If you are using it with a Wireless card as the onboard would need to be disabled, as it will look at that before your Wireless router

  daba 20:37 23 May 2005

Woodchip, The router/modem is connected to my PC via CAT5 Ethernet, there isn't a wireless card in the PC.

The wireless function of the router/modem is to enable my son's PC to use internet and share my printer. I have to have the 'on-board' enabled to talk to the router/modem via Ethernet. That is what I am having trouble doing.

The router is supposed to act like a DHCP server, issuing my PC with a TCP-IP address for Ethernet comms to take place.

  woodchip 22:51 23 May 2005

In IE typing in address bar do you get anything? or put http:// before the numbers and try see if it starts the setup page in router

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?