Problem retrieving partitions or data -what to do

  Ivor_Monkey 19:16 03 Jan 2008
Locked

Happy new year

This sia complicated problem, which may not have a fix.

I've replaced mobo and chip. I've repaired XP and things worked OK for a few days. I then got the new memory and when i installed I got a missing hal.dl and couldn't copy missing file over (access denied).

I then couldn't access primary drive which has
XP home on one partition with 3 or 4 partitions with music and photos etc. It seems that the Mbr was corrupt and so I tried fixmbr without any improvement.

To cut a long story short, I now get invalid partition table and can't boot from the drive, can't read the drive or see partitions. I suspect the mbr is corrupt. I tried several demos from data recovery programs (before buying (eg testdisk, etc) but the programs just usually freeze.

XP recovery disk does not see the XP OS for a repair so repair is out.

Question:

One option I have is to reinstall XP on the original partition, but if I do this i certainly lose any data on thatt partition,but does it help me with retrieving the data music files etc on the other partitions? Or does it (as I suspect) leave me with the same problem with those partitions?

Any views?

Thanks

  Jim_F 20:32 03 Jan 2008

Does the recovery disk let you access other partitions eg d: e: ? - if thats the case then installing XP on another drive is safest. The danger of reinstalling Windows on your current disk is that you may overwrite a partition with data on it if these are the only viable ones.

  Ivor_Monkey 22:10 03 Jan 2008

ßeta, thanks for your comment, but when set as a slave I cannot see any partitions. in fact, the disk is recognise din the bios and my computer but cannot be explored.

Jim_F, thanks, but I think the OS was orignally on the first partition, so my plan would be to make a clean install there in the hope that this might allow me to access the other partitions, but I'm not sure that it would.

  Jim_F 23:13 03 Jan 2008

Hi Ivor_Monkey,

Where I've been caught is that Windows tries to install in the first partition its sees - which may not be the first on the disk :)

Most disk management tools - including XPs dont like doing too much on the disk they're sitting on - do you see anything on the disk management console when you run the disk as slave ?

  UncleP 02:41 04 Jan 2008

The basic rule in trying to recover data from a damaged or corrupted disk is to treat it very, very carefully. This means not running any programs which might write to the disk (Windows itself sometimes undermines this approach by writing background material, beyond the control of the user). Even reading from the disk should be kept to a minimum, especially if the basic problem is that it is failing and the damage is cumulative. Ideally a low-level sector-by-sector copy should be made to a healthy HD, and data recovery attempted from that.

So I don't think that trying to re-install an OS onto a corrupted disk is a good idea in the first place - and in the second it's unlikely to work in the way you hope ie to recover the partitions. This means that it should be mounted as a slave in a working computer or as an external HD in a USB caddy.

Assuming that you have done one of these options, the next step is to look at the diagnostic information on the Disk Management page, as Jim_F suggests. You imply that there is a recognisable entry for your disk on the RHS of that page (probably as Disk1) at the top and/or in the list below Disk0, the C: drive. The information in these entries enables the condition of the HD to be estimated, and suitable action taken. Post it here and we'll see what we can make of it.

As you've surmised, the most likely areas of corruption are in the FAT, MBR, Partition Table etc, which prevents the structure of the HD contents being detected by the OS. Quite often, the program and data files are relatively untouched and may be recovered with a reasonable degree of success. The best programs for doing this read the individual sectors on the disk, and then piece them back together using information within each sector. It helps if additional material can be gleaned from the FAT etc, but this is not always essential.

These programs are not usually freebies, but most suppliers allow you to download a hamstrung version for free. If this detects some or all of your files, you are required to pay a price (£20-100) for them to be actually recovered and saved on another HD. It's your decision as to whether they are worth it or not.

If they don't find anything, the final option is to hand it over to a professional company. But that's usually an expensive affair, and I wouldn't bother to cross that bridge until you have to.

  Ivor_Monkey 11:24 04 Jan 2008

UncleP, thanks for your detailed reply. Much appreciated. I cannot see the drive in the disk management console. The machine doesn't even want to boot even as a slave.PC does not like the hdd connected. I wonder if the mobo is also suspect.

You mention some programs, but the demos I've used don;t work. Is there one that you recommend?

When hdd is in a cabby the diskmgmt doesn't find the hdd.

But using the powerquest program suggested by ßeta, the program sees the hdd in the caddy but I get
"Error reading the MBR at the specified sector". All numbers are zeros. except running axross the top is
163324 mb 20821 cyl, 255 heads, 63 sectors per track

[Sorry, I can't paste the table. Even screendumps aren;t working!]

Using another program (partition recovery program) runing dos program which ignores MBR I found this info:

Unallocated
Number of heads LBA
Number of cylinders LBA
number of sectors 63
Total Number of sectors 15509592
size 7.37 gb

logical? FAT12 20739

Unallocated 15530445

50524803
20 gb.

2 questions:
1. Any other ideas for retreiving data/partitions or programs that actually work?

2. How do i scan for mbr virus if the program doesn;t recognise the hdd?

Thanks again

  Ivor_Monkey 11:40 04 Jan 2008

Hold on, what's this...

The pc now sees it as a slave nd the diskmgmt.msc shows it as 31.50 gb healthy. The hdd is much larger than that 250, but 30 gb might jus tbe the fist partition.

This limit of 31.5 gb is odd. I'm now wondering whether I got myself confused with placing the jumper? Am I limiting the hdd drive to 32 gb when trying to set jumpers to slave? The hdd drive doesn;t like cable select, so i try to set it to slave.

  Ivor_Monkey 12:43 04 Jan 2008

Good news here are some numbers for the slave using the powerguest program:
type boot start head sector ending head sector
cyl
1 69 FF 68 13 10 288 115 43
2 73 50 371 114 37 366 32 33
3 74 20 371 114 37 372 97 50
4 00 00 00 00 00 00 00 00

sectors sectors
before
1 1869771365 168689522
2 1701519481 18969881465
3 2573 00
4 00 3435113472

Phew. I hope this helps...

Other strange things:
1) My security settings seeminly can't be changed from high, whch prevents me downloading certain files (capturing images).

2) Cannot scan slave drive for virus -mbr error can't read!

Oh dear....

  UncleP 13:23 04 Jan 2008

A quick response, as I'm going out after lunch and won't be back (let alone sober) until late this evening.

(a) agree that the 31.5 Gb size of the 'healthy' partition sounds a little suspicious, but not unreasonable for the first OS partition. On the other hand, it's just conceivable it might be one of the others - do you recall or have a record of the original partition sizes? Does disk management give any other information? - file system, used capacity etc. I'm not sure what the Windows' definition of 'healthy' is, it's certainly not the same as 'working'.

(b) I don't like to recommend programs in this area, as the level of success depends on machine configuration, the nature of the original fault and what has been done since. And my experience is limited to a few cases of different faults at most - hardly statistically significant! However, I mentioned in a recent similar thread that I had used Easeus Pro 3.0 for data recovery (on two single partition HDs) and Acronis Disk Director 10 for general partition management. Worth a try, I guess, if you haven't already done so.

  UncleP 13:31 04 Jan 2008

sorry, 'recent similar thread' = click here

  Ivor_Monkey 17:22 06 Jan 2008

Hi
Easeus Pro 3.0 doesn't seem to help and I'd already used Acronis without any joy.

Questions:

1) When putitng a HDD in a caddy, do i remove the jumpers?

20 I fiddled and made the first partiion active, which is what i thought it was orginally, but does switching a partition between active and inactive (logical?) have much effect on the data/partition?

I just want to see if i can retreive data/partitions form a HDD with an invalid partition table. I've solved some of the other myseries, but not retrieving the data.

And where are ßeta and Woodchip when you need them?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?