Problem networking two PCs with a crossover cable

  jz 22:16 23 Sep 2005
Locked

I have two PCs, one running XP SP2 (with Windows firewall enabled), the other running W2000 SP4 (with free Zonealarm firewall enabled). I've connected them together with a cross-over network cable.

Neither PC has an administrator password set.

The XP PC will only let me get access to the W2000 PC if I disable the firewall for the latter. Is there a way to have the firewall enabled and to still get access?

The W2000 PC will not let me get access to the XP PC, even if I disable the firewall for the latter. It prompts me for the XP password, but I haven't set one up!

  mgmcc 00:58 24 Sep 2005

<<< The XP PC will only let me get access to the W2000 PC if I disable the firewall for the latter. >>>

It is the firewall in the Windows 2000 PC that is preventing you from accessing, so you need to enter the IP addresses of the networked PCs in Zone Alarm's "Trusted Zone".

<<< The W2000 PC will not let me get access to the XP PC, even if I disable the firewall for the latter. It prompts me for the XP password, but I haven't set one up! >>>

By default, File & Printer Sharing is disabled in XP. Have you actually set any folders as "shared" in their Properties, because doing so will enable F & P Sharing. The request for a non-existent password is usually because F & P Sharing is still disabled. However, also have a look at this page - click here


I would also suggest you install the same free Zone Alarm in XP and disable Windows' own firewall which is only a "one-way" firewall and doesn't control outgoing internet traffic.

  jz 22:06 26 Sep 2005

Thanks mgmcc.

I've put the XP PC in Zone Alarm's trusted zone, so the XP PC can now access the 2000 PC.

I haven't tried your suggestions on the XP PC yet but will do shortly.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?