Problem getting Win98SE on the net...

  wotbus@ 20:20 27 Mar 2008
Locked

This old PC has a dial-up modem and has hardly been used (Compaq Desktop). It has been given to me for spares but I would rather get it Internet ready and pass it on.
I am on Broadband.
I have tried connecting it to my router via USB but it refuses to recognise the box other than to say Windows doesn't know the problem. (the drivers for the box support 98SE).
I have tried connecting via Ethernet after installing an Ethernet PCI card. This time everything indicates normal but the PC just won't speak to the box.
I have installed a spare wifi PCI card and again all is normal - net recognised and synced etc etc, but still IE is unable to "get out".
I have run Winsock fix, run IE6 repair option and generally checked IE options but still no joy. It's as though there is some Windows component missing but the CHKDISC ran no problems.
Any clues as to what I can check next.
Usually when I get "another" PC in my office I just plug it into my router ethernet/USB, run my box installation software disc and off it goes but this one with 98SE is refusing to budge :-(

  BurrWalnut 20:26 27 Mar 2008

1. Leave the Ethernet cable attached then check the NIC in Device Manager and reinstall it if necessary.

2. I used to run a little program called Lanlight that displayed the network icon in the system tray. I don’t know if it’s still available but Google should help.

  wotbus@ 20:45 27 Mar 2008

Cheers, I'll give it a try.

  Fruit Bat /\0/\ 20:46 27 Mar 2008

Firewall blocking?

  skidzy 20:50 27 Mar 2008

I think this is the little program BurrWalnut is talking about click here

Have you tried loading Firefox to the 98se machine and see if this connects ?

  wotbus@ 21:02 27 Mar 2008

The symptom is exactly like a firewall but there is no 3rd party f/w installed. I have the program BurrWalnut suggested but decided not to play any more until tomorrow (no hair left to pull out :-)
I have installed the latest FF by installing from a CD and the sympton is the same. It's almost as though the net protocol bit is adrift or corrupt but cursory checks everywhere appear normal. I have checked the obvious like Work Offline.
The only thing I have done to it is run the Norton removal tool to get rid of Norton2005 which appears to be the last time it was on the internet.

  wotbus@ 21:07 27 Mar 2008

PS I can see the "world" in IE turning as it tries to connect but it just times out with the "cannot display page" etc. I have also run AV and CCleaner but nothing to speak about.

  Strawballs 22:08 27 Mar 2008

When connected by wire did you go into internet options and set it to connect through Lan?

  wotbus@ 08:41 28 Mar 2008

I am sure I did but it's worth a check. I have just started to try resolving the problem so I will post back later today, thanks for the tip.
It certainly appears to be something simple like a mis-config somewhere.

  wotbus@ 09:13 28 Mar 2008

Got it. It was a configuration problem.
IE6 / Options Internet / Connections / LAN settings.
Ticked Auto detect settings box and the Proxy server box and completed the details.
I am now up and running on the wifi card so will leave it at that for the moment.
Big thanks to all who responded.
:-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?