problem formatting external hard drive

  Josie2805 09:53 18 Nov 2008
Locked

When formatting a WD 1TB external drive the computer was shut down & when restarted the drive was not accessible. Right clicked & tried to format but hours later message came up 'cannot format'. Search of the site found click here which matched exactly the message, so tried format from disk management. This has now been going for 12hrs & still only 4%, can someone tell me can that possibly be right?

  dogtrack 10:26 18 Nov 2008

Given its 1000 GB capacity...possibly. In particular if you have a relatively "slow/old" PC. And or, other services running in the background. Suggest you just let it get on with it...it will finish, eventually.

  Josie2805 10:29 18 Nov 2008

OK, it's plugged in via usb1 hub so that may be the problem. I'll leave it and see before I tick resolved. Thanks

  johndrew 10:31 18 Nov 2008

Seems a very long time to me.

I presume you are formatting in NTFS?

Have you tried the suggestion made by Fruit Bat /\0/\ Tue, [email protected]:36 in your link?

  Josie2805 11:00 18 Nov 2008

Johndrew I wouldn't have a clue how to start putting it as a slave drive. I wasn't really sure what fdisk was. When I right clicked on it in disk management one of the options was delete volume (no mention of partition) so I did that & then selected format. Yes it is NTFS, starting to wish I'd just left it as FAT32 it was when it came out of the box.

  Josie2805 11:04 18 Nov 2008

I've just had another look & it's still sitting at 4% (that's been about 2 hrs now, it was 1% when I left it last night, after about 4 hrs). The only option when I right click is 'cancel format'. Do you think it's damaged as a result of the computer having been turned off during original format?

  Josie2805 15:58 18 Nov 2008

Will tick this as resolved, finally cancelled format & retried with 2 500gb partitions & it formatted ok in a short time (compared to about 15hrs when I gave up original format)

  johndrew 16:36 18 Nov 2008

I think your main problem was the lower transfer speed of USB1. It may well have been quicker plugged directly into a PC USB2 port rather than through the hub.

You have probably done the right thing in breaking it into 250GB partitions. I know that my external only took about 45 minutes to format and that is 250GB.

  David4637 18:30 18 Nov 2008

May be worth considering partitioning the drive, if only to confirm it will format in a reasonable time or not??? David

  Josie2805 18:31 18 Nov 2008

Thanks for all the help, I got it formatted as 2 500gb partitions & all seems to be working ok.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?