Problem "finding" the printer

  andy625 10:49 22 Feb 2011

I have an Lenovo laptop, and Epson B40W wireless printer. They've worked well together for the last few months, however just recently whenever I start Work, it hangs, and I get the following message.

"The printer has not yet responded, but microsoft office may be able to proceed without printer information. Do you want to continue to wait for the printer?"

If I click "yes" it hangs for about 20-30 seconds before finally opening and being ready to do anything.

If you click "no", word starts but when you go to print, the printer name is blank. If I then click the down arrow, and select the Epson (default) printer, it hangs again for about 20-30 seconds before finally finding the printer and allowing me to print.

I get a similar hanging problem when opening Adobe to print a pdf.

I have a netbook set up to use the same printer on the network, which still works fine with Word and Adobe.

I've tried deleting the printer from the laptop and reinstalling it, uninstalling and reinstalling word, deleting the "" files associated with word, disk cleanup, rebooting the router etc.

If I set the default printer to Adobe Distiller, Word opens as normal, but I still get the same hangups when I try and tell it to print to the Epson.

Anyone got any ideas whats happening?

  andy625 14:12 22 Feb 2011


  andy625 17:25 22 Feb 2011

I was thinking of trying the cable route and maybe sacrificing the wireless capabilities to make it reliable at least. I'm not sure how to assign a static ip address.

  andy625 10:37 23 Feb 2011

Tried connecting with a USB cable and turning off the wifi on the laptop, and it made no difference.

The problem seems to be the worst in word, where it wont find the printer for about 30secs - 1min, then it takes another minute before the printer will actually print it out. And all it is printing is 1 sheet of A4 with two lines of text.

Sounds to me like its a problem with the pc rather than the printer or network. Our netbook prints from word with no problems. As I said, I've reinstalled the printer, uninstalled and reinstalled word. Its running word 2003 on xp pro.

  andy625 17:17 23 Feb 2011

Anyone got any ideas??

  rawprawn 17:38 23 Feb 2011

Re install drivers

  andy625 20:19 23 Feb 2011

Already done that.

  andy625 13:13 24 Feb 2011

I'll give that a try. I did reinstall the drivers the other night, but didn't delete the printer first.

  andy625 10:38 02 Mar 2011

Finally got around to deleting the epson printer and all references to it in the server tab of the printer & faxes window. Reinstalled as a usb printer with latest drivers - no difference.

The printer can be used as a wireless printer or usb. So uninstalled again made it wireless - no difference. Still get the:

"The printer has not yet responded, but microsoft office may be able to proceed without printer information. Do you want to continue to wait for the printer?"

error. Click yes, wait for about 30secs to get the "printer ready" in the print box, press print and it takes ages 1-2 min before it actually prints. It will always print eventually, just taked about 3-4 mins total.

Error happens in all applications, office, adobe, firefox. Tried uninstalling and reinstalling office, even installed open office. No different.

We have 2 netbooks that also print to this printer wirelessly, and they are both fine.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?