problem with epson printer

  bendigo 16:57 27 Apr 2007
Locked

My elderly epson stylus photo 750 does not think it is out of black ink, so the 'out of ink light' is not lit and I can't go through the usual procedure to replace the cartridge. If I start the procedure, all that happens is the start up sequence. How do I get the ink carriage to emerge from its housing so that I can change cartridge? Trying to get any sense from the online site is like knitting fog-- can't be done!!!! Any ideas anyone?
Thanks in anticipation.

  Diemmess 17:15 27 Apr 2007

From memory because I HAD but no longer do have a 750.
Brutal perhaps, but make the sequence begin and switch off....
A bit like trying to judge when the windscreen wipers are vertical in an old car about to suffer an unsympathetic car wash.

There may be other trouble in the background and if the black pathway is dry, it may be worth being very patient -

A couple of head cleaning procedures and then leave overnight to let ink diffuse along the pathways and for all micro bubbles to disperse.

  Woolwell 18:03 27 Apr 2007

From the Epson site:
Make sure the printer is on. The
P power light should be on,
but not flashing. (Determine which cartridge needs to be
replaced as indicated by the
B black and
A color ink out light.)
2. Lower the output tray at the front of the printer, then open
the printer cover.
3. Hold down the
R cleaning button for three seconds until the
print head moves left slightly to the cartridge replacement
position and the
P power light begins flashing.

The Epson site for the 750 is: click here

  Woolwell 18:05 27 Apr 2007

However if it is not printing in black and there is no indication that it is out of ink then as Diemmess states there may be other trouble in the background. The head cleaning procedure is good advice.

  bendigo 20:50 27 Apr 2007

Sorry should have made it clear that the normal cleaning procedures have been carried out several times, initially showing gaps in the black pattern, then the black pattern disappeared apart from a few horizontal specks above where it should have been. As neither of the indicator lights appear the printer will not give me access to the cartridges. As suggested I have tried the 'brutal' approach but it doesn't work. The sneaky thing carries on for a while and then shoots into cover before closing down. Any more ideas guys?

  Woolwell 21:38 27 Apr 2007

Doesn't sound too good. Sorry but it may be time to look for another printer.

  Stuartli 23:31 27 Apr 2007

A new, even better Epson printer could well cost you a lot less than you paid originally for the 750.

  jack 08:44 28 Apr 2007

I had a 750 same probs- this is how I got over them
1. To access the carts, start clean cycle- then when the cart carrier is right place - pull the power cord out.
The jets look like they may have clogged.
If you have an empty cart laying around- take a refill syringe and fill it with an alcohol based solution- this can be- car windscreen washer/window cleaner/10% Propanonal-Alcohol[if you can find it] or even 10% vodka/gin- fill the carts -reconnect power and run cleaning cycles.
If you can lay your hands onto some fine tubing or a drinking straw cut a piece to make a connector between syringe and the spigot in the base of the cart holder- and pump cleaning solution[as above]
back and forth with vigour.
Then try .

  Diemmess 08:54 28 Apr 2007

As you have found out "the thing continues."
I meant like Jack has said, pull the power plug out of the back of the printer at the appropriate moment.

  bendigo 23:18 28 Apr 2007

Thanks everyone, I did the 'pull the plug' bit, but the problem persisted so I am now the proud owner of a 'Canon Pixma iP6700D'----awesome!!, well a considerable advance on my Epson. Lots of new stuff to learn though. Problem solved, thanks again.

  Diemmess 09:39 29 Apr 2007

Glad you have taken the plunge and bought a replacement.
Pulling the plug is NOT recommended by any manufacturer, it can upset the firmware and generally make life difficult.

I'm sure it would have survived the brutal approach, but it did pose the question "Why did it behave like that in the first place?"

All the Epson printers I have had have obeyed the correct buttons to allow a change of cartridge at any time, whatever misbehaviour might have been occuring. I think your old 750 was in real trouble.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?