Problem card reader on a Toshiba A300-1MC

  eysha1 13:18 18 Aug 2012

I have been into the device manager and it shows a yellow question mark against th Ricoh xD card disk device. I checked for updates and i am all up to date on everything. I would love to get it working again so i can see the photographs i take. Any help advice would be great. Maybe there is a link i have missed somewhere while looking for a device update or something. If there is somewhere to download something please send the exact link. Many thanks. E.

  KRONOS the First 13:32 18 Aug 2012

I can only suggest going into device manager and removing the card reader driver then downloading and installing whichever one you need from here.

  eysha1 13:55 18 Aug 2012

Found the driver i need but cannot seem to get it into the device manager so need help there please. Not done this before so lost on this bit. Instructions please. Many thanks E.

  rdave13 14:01 18 Aug 2012

Have a look here. I've downloaded the win 7 64-bit zip file and scanned it. All clear.

  rdave13 14:02 18 Aug 2012

Usually you just extract it and run the file.

  eysha1 22:34 18 Aug 2012

I did extract it and tried to run it but maybe i am doing something wrong as it isn't working - HELP.

  rdave13 22:42 18 Aug 2012

Where did you get this driver? You can go to Device manager,right click Ricoh xD, select update driver software, then select Browse my computer for driver software. The site I posted to for the driver has virus free downloads as to the 64-bit I downloaded. Have you checked your file for potential malware/virus ?

  eysha1 22:48 18 Aug 2012

i went to the site you said and downloaded it, still no good. I also went to device manager and it tells me it is updated so no new ones available. The card reader still isn't working and there is still a yellow question mark on the Ricoh card reader device.

  rdave13 22:56 18 Aug 2012

OK. Make sure you safely remove any external drives you have connected to your PC including flash drives or any backup hard drives. Once done go back to device manager and right click Ricoh xD . Select uninstall. Click on yes to remove. Reboot the PC and once on the desktop you should see Windows installing the generic driver for your card reader. See if it now works. If it does then make sure Windows updates does not update the driver for it automatically.

  eysha1 13:34 20 Aug 2012

Thanks rdave. I followed your instructions and downloaded it from the same site as you then uninstalled it in device manager and re-started the laptop as you said. However, going back into the device manager to check it all again i found exactly the same fauly as described above, a yellow question mark on the RICOH xD card eader device. Any idea why this is happening? I am lost.

  Secret-Squirrel 13:52 20 Aug 2012

" .......a yellow question mark on the RICOH xD card eader device."

It would be good to discover what the problem is exactly so double-click on that problem Device Manager entry and let us know what the error details are. If there's an error code shown then let us know that too.

When you reply, let us know which version of Windows you're running. It's probably the 32-bit version of Vista but it may help to get confirmation.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?