Problem with CanoScan 2700F and XP

  claypuddler 22:34 30 Apr 2005
Locked

I have recently purchased a Mesh Elite A6 with Windows XP Home.
I have a CanoScan2700F slide scanner which I previously connected to my older Mesh running off Windows 98 via a SCSI card which came with the scanner.
I fitted an Adaptec 2904 SCSI-PCI adapter, which came with an installation guide with no mention of XP.
I also had to purchase a new cable to connect the 50-pin connector on the card to the scanner (25pin SCSI)
I searched in vain for a driver until I found Adaptec’s website which states that the driver is embedded in XP.
I downloaded the CanoScanFS software for XP from Canon’s website, ran the ensuing file ‘s2305enx.exe’ and unzipped its contents.
On running the SETUP file (by double clicking Explorer) I end up with the message :
! Warning : Please make sure your SCSI devices are Connected Properly and Turned On
Pressing ok gives another message :
Configuration Manager
X Error reading SCSI Device
I have double checked/tightened the screws on the 25-pin connector from the cable in to the scanner. It still does not work, however.
How can I check if the problem does lie with the connection ?
Is there something else which could be causing my problem ?
The Adaptec guide states that the card is permanently set to SCSI no. 7.
The Scanner is set to SCSI no.2 with terminator ‘ON’. I have no other SCSI devices connected.
My Computer Device Manager shows that under ‘SCSI and RAID controllers’ there is an ‘Adaptec AIC-7850 PCI SCSI Controller’ showing that at least the card has been detected.
For a while it also showed, under ‘Other devices’ a ‘CANON IX-27015C SCSI Scanner Device’ with a question mark to the left of this name. Now, however, after a few more tweakings of the connections and re-bootings this seems to have disappeared from the Device Manager listings.
Can anyone help, please ?

  john-232317 08:14 01 May 2005

Have you had a look in device manager, in scsi and raid controllers, is the card there with no yellow marks ? I had a similar problem with my HP scanjet 5p which runs off a future domain adapter scsi card. Although the driver was in xp it would not use it because it had not been certified or similar wording, i had to put it in from the list of drivers, once i did this it worked fine.

  claypuddler 19:00 05 May 2005

Thanks dadyassa. I have been trying to understand this more, without much success. Where do you put the driver to get it certified ? In my drivers folder in XP under Windows\DRIVERS\SCSI\ADAPTEC there is only one folder, 1200A. Inside that in \Win_XP there are 4 files : hpt3xx System file ; hpt3xx Security Catalog ; htp3xx Setup Information ; and XPreadme. I have printed off the Readme and I cannot say I really understand it ! I am also concerned that my Adaptec card is type 2904. Can I use the driver hpt3xx from 1200A ?

  jack 20:05 05 May 2005

As a generality older scanners with Win98
Software don't take to XP.

It seems that a scanner has firmware that controls the scan rate resolution tracking etc,
that is set in DOS. and will only run with DOS commands.
So NTFS it no like.

Some scanner makers [ Mustek for one]
tried to do a conversion down load bit it did not go too well

Try this
Right click on the scanner software icon
At the bottom click on properties then the campatability tag
Follow the prompts to set the prgram to read as for Win98.
See what happens.
If no go- then it is probably a new scanner for you.

  john-232317 08:19 07 May 2005

The problem may be scsi card driver or scanner driver.

Go into device manager and check there are no yellow marks on the scsi card, Double click on it and it should say " this device is working ok "

If it does go back to device manager and in imaging devices, double click on your scanner and you should have the same message.

It may say drivers are not loaded, if it does go into the drivers tab and update driver, i chose select from list and the HP drivers were there, but because MS cant be bothered to check if old drivers work they say they are un certified just to cover themselves, but let you install them yourself from the list,

  Bagsey 10:00 07 May 2005

I had a similar problem and messed about trying to find new drivers for my Canoscan and eventualy tried "compatability mode" and it worked.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?