Problem with Belkin wireless utility

  FreddyNoFriends 01:36 24 Sep 2006

Hi all.
I recently installed WinXP onto an old P3 500Mhz desktop, and fitted it with a wireless F5D7000 Belkin Wireless network card.

I've set up the card to connect to my secured home network (Belkin router), just like the other 3 computers we have in the house, and the icon on the tool bar tells me that I'm connected and the signal strength is "good" or "excellent".

All seems hunky dory, but on opening Internet Explorer, I'm unable to connect to any pages on the internet. The IE toolbar tells me it's trying to connect to a website, but I eventually get the "Page cannot be displayed" message.
Thing is, other programs such as Outlook do connect and I've sucessfully sent a test email.

Needless to say, all the other computers in the house connect just fine, so it's not a router problem - at least I assume it's not.
I've tried disabling the XP firewall, tried changing the setting to let windows configure the wireless network, all to no avail.

I'm now wondering if the combination of XP, Internet Explorer and the Belkin software are simply too much for the old machine to handle.
Can anyone tell me if this is the case, or whether there is anything else I should try?

I'm about at the limit of my knowledge now, so I'd be very grateful for any info or advice.

  Taff™ 09:08 24 Sep 2006

You need to perhaps check that you have the correct driver installed. Look on the packaging of the F5D7000 and see which version you have. It`s also printed on the adapter itself. Drivers available click here

Can`t see that the age of the machine has anything to do with it. If it`s running XP already this simple request won`t stretch it! Check in IE Tools>Internet Options> Connection Tab that "Never Dial a connection" is selected.

  ade.h 16:23 24 Sep 2006

"...the Belkin software"

It is common knowledge that, while its routers are mostly very good, the software is more problematic than most. Don't install it.

  Strawballs 17:20 24 Sep 2006

Had same problem with neighbours machine he had belkin USB wireless adapter with it's software installed and all I did was uninstalled the software and let windows manage the wireless and all worked fine (as ade.h said) all I left was the drivers.

  FreddyNoFriends 22:25 24 Sep 2006

Thanks for the advice guys, but I'm still stuck.

I've checked the drivers and they're up to date.
I've reinstalled the network card - twice - and it seems to function fine - though still wont connect to the internet.
I've checked in my router set up page and it says this particular computer is connected to it.
The Belkin utility - initially - told me I'm connected to the network and have full signal strength.
However, when I try to open the Belkin utility now, despite two reinstalls, the utility screen appears for a couple of seconds then closes again.
And each time I reboot, the green screen "Connected" icon appears on the tool bar for a few seconds then closes.
This has happened each time I've reinstalled.

I've tried ticking the "Let windows configure network settings" box, but to no avail.

How do I go about removing the Belkin software without removing the drivers? I uninstalled the Blekin software earlier, but the driver seemed to go with it, and when I tried to install just the drivers on their own, the "Update driver" utility simply wouldnt find them, even when I downloaded it from the internet and then browsed to the folder I'd just put it in. The folder appeared empty.

Given the behaviour of the Belkin utility, it seems it's being shut down again moments after it opens. I've turned off the Windows firewall and that makes no difference. I'm thinking it must be some sort of software conflict but I'm totally stumped as to what.

Or have I just got a dodgy network card?

Anyone know what this might be...?

  ade.h 22:35 24 Sep 2006

"I've tried ticking the "Let windows configure network settings" box, but to no avail."

That won't work until the software is gone. click here and scroll down.

  FreddyNoFriends 22:52 24 Sep 2006

I think I figured this out - I went to Network Connections in Control panel.
Then opened "Network Connections", right clicked on the "Wireless Network Connection" and selected properties.
Under the "wireless Networks" tab, I ticked "Use Windows to configure my wireless network settings" then highlighted and "Removed" my network details from the preferred networks box, and clicked OK.
Windows then found the available networks and after entering my network key, it simply connected!

Hope this helps someone else!

Thanks for all the advice chaps!!

  Taff™ 06:46 25 Sep 2006

You`ll find that your network has been put back into the "preferred networks" - The trick is to highlight it and use the Up/Down arrows to the right to move it to the top. You can safely delete any others anyway.

  FreddyNoFriends 18:38 25 Sep 2006

Hmm. I just tried to get rid of the Belkin software and reinstall the drivers only - which I just downloaded from Belkin - but my system wont recognise the driver even when I browse to the folder its in.
Anyone know what I'm doing wrong?


  Taff™ 11:29 26 Sep 2006

Have you checked the version number - refer to my earlier post & link. When installing the driver opt to select the correct driver from a list. You should then see the different driver versions.

  FreddyNoFriends 00:27 27 Sep 2006

Again, thanks for the assistance everyone.

I double checked and downloaded the right drivers, got it running, and it's worked fine for a while, even after several reboots.
But it's now randomly dropping out again and wont find any networks, even though there are four in range down my street. Thing is, the device manager says the network card is working fine.
So I'm stumped again!

Dodgy card maybe?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires