PRINTING FROM INTERNET

  midders 15:03 18 Nov 2007
Locked

I have a recently installed Dell Dimension C521 and use a fairly old (2000) Epson Stylus Color 460 printer. I use a USB to parallel printer cable. I am having problems printing from the Internet. I can print PDF files and documents offline. When I print documents from the Internet (e-mails, bank statement,etc.) all I get is gobbledegook (meaningless number, letters and other symbols). I have spent a considerable sum of cash phoning internet support of my ISP but they are unable to help. As anyone got a solution please?

  FreeCell 15:15 18 Nov 2007

What browser are you using? IE7.

If so try launching without add-ons (right click on desktop icon and select Start without add-ons).

Do you still get the same problem? This isolates any additional programs that you may have loaded such as Google browser toolbars, etc

  midders 10:48 19 Nov 2007

Sorry, FreeCell I've tried that but the problem remains

  keef66 11:08 19 Nov 2007

Are you using Windows Vista? If so, have you installed a Vista driver for your printer? Or does such a thing not exist because of the age of your printer, in which case I suspect it may be the cause of your problems.

  FreeCell 11:19 19 Nov 2007

No problem.

Are you using Vista? Could be driver problem with an older printer.

Clarification. You say printing from internet but mentioned emails. Were these printed using your browser (webmail) or from an email program like Windows Mail, Outlook Express?

Another test: if you use Print Preview does it show the same "gobbledegook" as is printed out. Isolate problem from browser and print spool/driver.

  midders 13:42 19 Nov 2007

Using Windows XP. "gobbledegook" also shown on Print Preview. Same result when try to print out emails. Using explorer 7

  FreeCell 14:56 19 Nov 2007

In IE7 - Tools - Internet Options under Security tab check the following advanced seettings

Download ActiveX Controls - Enabled

Script ActiveX control marked as safe for scripting - Enabled

Restart PC.

Still the same?

Potential ScriptX problem

  anchor 15:15 19 Nov 2007

I read on another forum that you are not alone with this problem.

It appears that Epson have not released a Vista driver for your printer as it is now about 7 years old. I have just looked here to check;

click here

That is most probably the cause of the trouble. If nothing works, then I am afraid it means a replacement printer. However, the newer ones are much better.

  FreeCell 15:18 19 Nov 2007

anchor
Please note midders has already stated they use Windows XP. Lack of Vista drivers is not the problem therefore.

  anchor 15:28 19 Nov 2007

Just noted that you have Win:XP; sorry about the confusion. I assumed that your new PC had Vista.

I guess that you have the latest XP driver for your printer, it is quite old, dating back to Jan 2004.

click here

  midders 15:47 19 Nov 2007

Went into Internet Options and then clicked "security" tab but two ActiveX options were not listed. Can print documents off line like Wordpad and also PDF documents from the Internet

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?