Printer not working - USB not recognised

  Guady 18:04 23 May 2009
Locked

I wonder if someone can help! Suddenly today when I tried to print a Word document - nothing happened. Then I got a message saying that Windows did not recognise a USB device, which must be the printer - as all other items seem to be working correctly. I tried deleting document from the printer queue but this did not help. I've checked all the connections, and tried the printer in another USB port. Does anyone have any ideas of what I might try, please? Co-incidentally the PC also seems to be running slowly since this happened - could it be related? Look forward to any advice. Thanks

  Fruit Bat /\0/\ 18:10 23 May 2009

Uninstall and reinstall all your printer software and drivers in device manager.

  Guady 09:48 24 May 2009

Many thanks

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?