Printer not working from PC

  Chrissib 17:01 25 Feb 2009
Locked

Hi, have a problem with my printer not communicating with my PC. The printer is a Lexmark 5400 all in one.

The thing is, I can print from a Laptop, via the same cable, but not from any USB port on the PC. The same USB ports drive other peripherals ok. Both using Windows XP. Been onto the helpdesk at Lexmark, and they say it's something to do with spooler in Windows, but I dont know how to check this. Don't really want to re-install Windows if I can help it, because it all works apart from the printer.

Any assistance appreciated
Regards Chris

  MAT ALAN 17:06 25 Feb 2009

click here

this may help...

  peter99co 17:21 25 Feb 2009

If you set up a router and create a network it is possible to use the printer on both computers.

I have a printer connected to PC and Laptop is WIFI

If I open the PC on My network places on the laptop, any Laptop document clicked for print is then printed.

  Chrissib 16:39 26 Feb 2009

Thanks Mat Alan, the information looks good but I dont get spooler errors. The only error I get is from Lexmark application 'Communication Not Available'. If I connect my Laptop using the same cable, it works fine.

Further, following the instructions, I have no 'LexBce Server' listed. And my spooler says it is started.

  MAT ALAN 18:28 26 Feb 2009

You can give this a try.
Click Start, right-click My Computer, and then click Properties.
Click the Hardware tab, and then click Device Manager.
Expand Universal Serial Bus controllers, right-click USB Root Hub, and then click Properties.
Note: There may be more than one USB Root Hub installed in your computer. In this case, you may have to follow these steps with each USB Root Hub device.
Click the Power Management tab, uncheck the box "Allow the computer to turn off this device to save power", and then click OK.

  Chrissib 12:11 27 Feb 2009

Had 5 USB root hub entrys, and have unchecked all, but still not working.

  Fruit Bat /\0/\ 15:26 27 Feb 2009

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
or
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  woodchip 16:38 27 Feb 2009

Try removing all Lexmark from Your computer with the Printer USB removed. This includes Add Remove Programs and Manual check of Windows Explorer do a Search for Lexmark and remove all you find. Then reboot Reload CD and plug the Printer in when it starts looking for the printer

  Chrissib 11:41 04 Mar 2009

I have tried deleting USB devices but keep losing my mouse and keyboard, then cant do anything. Have to plug in another mouse and go through restore to get back.

  Chrissib 12:31 04 Mar 2009

I have tried uninstalling the Printer and all related Lexmark files. Rebooted + Re-installed the software from CD, and still does not communicate. The test page occasionally starts to print, gets buffer 20% and hangs.

  Chrissib 11:58 26 Mar 2009

OK i'm beaten, tried all suggestions and nothing improves, can only assume a reload of Windows will clear this problem.

But is there any way i can re-install windows or repair, without losing my current settings, IE video, CD roms, sound, keyboard/mouse etc...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?